aboutsummaryrefslogtreecommitdiff
path: root/lang/julia10
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2019-06-16 04:38:11 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2019-06-16 04:38:11 +0000
commit86bba359018a7e1446db6b19b24a5a447713e073 (patch)
tree85b79d6c2a66ffa1343748a58ef94355ad487131 /lang/julia10
parent85d53791c7903e57383cf2bdc0fcacef27de64f7 (diff)
downloadports-86bba359018a7e1446db6b19b24a5a447713e073.tar.gz
ports-86bba359018a7e1446db6b19b24a5a447713e073.zip
- Update to 1.0.4
Submitted by: Iblis Lin <iblis@hs.ntnu.edu.tw> (maintainer)
Notes
Notes: svn path=/head/; revision=504279
Diffstat (limited to 'lang/julia10')
-rw-r--r--lang/julia10/Makefile8
-rw-r--r--lang/julia10/distinfo6
-rw-r--r--lang/julia10/pkg-descr9
-rw-r--r--lang/julia10/pkg-plist6
4 files changed, 14 insertions, 15 deletions
diff --git a/lang/julia10/Makefile b/lang/julia10/Makefile
index 644642e22cfe..5b3b16f985dd 100644
--- a/lang/julia10/Makefile
+++ b/lang/julia10/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= julia
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
DISTVERSIONSUFFIX= -full
CATEGORIES= lang math
MASTER_SITES= https://github.com/JuliaLang/julia/releases/download/v${PORTVERSION}/
@@ -33,6 +33,8 @@ USES= gmake compiler:c++11-lib fortran python:2.7,build perl5 \
shebangfix
USE_LDCONFIG= yes
+DESCR= ${.CURDIR}/../julia/pkg-descr
+
SHEBANG_GLOB= *.sh
WRKSRC= ${WRKDIR}/julia-${PORTVERSION}
@@ -133,8 +135,8 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ui_Makefile
.endif
post-extract:
- ${GMAKE} -C ${WRKSRC}/deps extract
- ${GMAKE} -C ${WRKSRC}/stdlib install
+ ${MAKE_CMD} -C ${WRKSRC}/deps extract
+ ${MAKE_CMD} -C ${WRKSRC}/stdlib install
post-patch:
echo "override TAGGED_RELEASE_BANNER=\"FreeBSD port lang/${PORTNAME}${PKGNAMESUFFIX} build\"" >> ${WRKSRC}/Make.user
diff --git a/lang/julia10/distinfo b/lang/julia10/distinfo
index 66fd9dd86e2e..7f7181ced73d 100644
--- a/lang/julia10/distinfo
+++ b/lang/julia10/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1552292755
-SHA256 (julia-1.0.3-full.tar.gz) = 618e6d29f1fba00f5b2bebf14e69a3a536c27c3132e021cf39774e8500dd29fa
-SIZE (julia-1.0.3-full.tar.gz) = 95732731
+TIMESTAMP = 1559889707
+SHA256 (julia-1.0.4-full.tar.gz) = bbc5c88a4acfecd3b059a01680926c693b82cf3b41733719c384fb0b371ca581
+SIZE (julia-1.0.4-full.tar.gz) = 95865812
diff --git a/lang/julia10/pkg-descr b/lang/julia10/pkg-descr
deleted file mode 100644
index 461e454f79d4..000000000000
--- a/lang/julia10/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-Julia is a high-level, high-performance dynamic programming language for
-technical computing, with syntax that is familiar to users of other technical
-computing environments. It provides a sophisticated compiler, distributed
-parallel execution, numerical accuracy, and an extensive mathematical function
-library. The library, largely written in Julia itself, also integrates mature,
-best-of-breed C and Fortran libraries for linear algebra, random number
-generation, signal processing, and string processing.
-
-WWW: https://julialang.org/
diff --git a/lang/julia10/pkg-plist b/lang/julia10/pkg-plist
index e572b4c6bd7f..8bb7901b9159 100644
--- a/lang/julia10/pkg-plist
+++ b/lang/julia10/pkg-plist
@@ -501,6 +501,7 @@ man/man1/julia10.1.gz
%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/NastyGenerator.jl
%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/api.jl
%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/pkg.jl
+%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/project/good/pkg.toml
%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/repl.jl
%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/resolve.jl
%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/resolvedata1.jl
@@ -526,6 +527,10 @@ man/man1/julia10.1.gz
%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/test_packages/BigProject/test/LibFoo.jl/test/runtests.jl
%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/test_packages/BigProject/test/REQUIRE
%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/test_packages/BigProject/test/runtests.jl
+%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/test_packages/BuildProjectFixedDeps/Manifest.toml
+%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/test_packages/BuildProjectFixedDeps/Project.toml
+%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/test_packages/BuildProjectFixedDeps/deps/build.jl
+%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/test_packages/BuildProjectFixedDeps/src/BuildProjectFixedDeps.jl
%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/test_packages/PackageWithBuildSpecificTestDeps/src/PackageWithBuildSpecificTestDeps.jl
%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/test_packages/PackageWithBuildSpecificTestDeps/test/REQUIRE
%%JULIA%%/share/julia/stdlib/v%%VERSION%%/Pkg/test/test_packages/PackageWithBuildSpecificTestDeps/test/runtests.jl
@@ -686,6 +691,7 @@ man/man1/julia10.1.gz
%%JULIA%%/share/julia/test/codegen.jl
%%JULIA%%/share/julia/test/combinatorics.jl
%%JULIA%%/share/julia/test/compiler/compiler.jl
+%%JULIA%%/share/julia/test/compiler/irpasses.jl
%%JULIA%%/share/julia/test/compiler/ssair.jl
%%JULIA%%/share/julia/test/compiler/validation.jl
%%JULIA%%/share/julia/test/complex.jl