aboutsummaryrefslogtreecommitdiff
path: root/lang/kturtle
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-09 16:54:36 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-09 16:54:36 +0000
commit96c4a6fb54b361be281ba571c59c1a9053abbec7 (patch)
treec09826431ab288362da965b46c50ef35ab244d41 /lang/kturtle
parentdd150900f438c6df56e299e01f466104833040a2 (diff)
downloadports-96c4a6fb54b361be281ba571c59c1a9053abbec7.tar.gz
ports-96c4a6fb54b361be281ba571c59c1a9053abbec7.zip
New port: lang/kturtle, lang/kross-interpreters
This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4.
Notes
Notes: svn path=/head/; revision=466868
Diffstat (limited to 'lang/kturtle')
-rw-r--r--lang/kturtle/Makefile17
-rw-r--r--lang/kturtle/distinfo3
-rw-r--r--lang/kturtle/pkg-descr17
-rw-r--r--lang/kturtle/pkg-plist109
4 files changed, 146 insertions, 0 deletions
diff --git a/lang/kturtle/Makefile b/lang/kturtle/Makefile
new file mode 100644
index 000000000000..afb9556c350e
--- /dev/null
+++ b/lang/kturtle/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= kturtle
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= lang kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Educational programming environment for KDE
+
+USES= cmake:outsource gettext kde:5 tar:xz
+USE_KDE= attica auth codecs config configwidgets coreaddons crash ecm \
+ emoticons i18n init itemmodels kdelibs4support kio newstuff \
+ service sonnet textwidgets widgetsaddons xmlgui
+USE_QT5= core dbus gui network printsupport svg widgets xml \
+ buildtools_build qmake_build
+
+.include <bsd.port.mk>
diff --git a/lang/kturtle/distinfo b/lang/kturtle/distinfo
new file mode 100644
index 000000000000..5b6fb29d585a
--- /dev/null
+++ b/lang/kturtle/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520519335
+SHA256 (KDE/applications/17.12.3/kturtle-17.12.3.tar.xz) = 48732daada7b110a518c305ea72200ddc6082e41a2c3923cd3d3b0e0f1bdf7d4
+SIZE (KDE/applications/17.12.3/kturtle-17.12.3.tar.xz) = 1608852
diff --git a/lang/kturtle/pkg-descr b/lang/kturtle/pkg-descr
new file mode 100644
index 000000000000..eb1c114f5db0
--- /dev/null
+++ b/lang/kturtle/pkg-descr
@@ -0,0 +1,17 @@
+KTurtle is an educational programming environment for KDE. KTurtle
+aims to make programming as easy and touchable as possible, and
+therefore can be used to teach kids the basics of math, geometry
+and... programming.
+
+The programming language used in KTurtle is loosely based on Logo.
+KTurtle allows, just like some implementations of Logo, to translate
+the programming language (the commands, the documentation and the
+error messages) to the native language of the programmer. Translating
+the programming language to the native language of the programmer is
+one of the many ways KTurtle tries to make learning to programming
+more simple. Other features to help to achieve this goal are:
+intuitive syntax highlighting, simple error messages, integrated
+canvas to make drawings on, integrated help function, slow-motion or
+step execution, and more.
+
+WWW: http://edu.kde.org/kturtle
diff --git a/lang/kturtle/pkg-plist b/lang/kturtle/pkg-plist
new file mode 100644
index 000000000000..e1faabc6cfe5
--- /dev/null
+++ b/lang/kturtle/pkg-plist
@@ -0,0 +1,109 @@
+bin/kturtle
+etc/xdg/kturtle.knsrc
+share/applications/org.kde.kturtle.desktop
+share/icons/hicolor/128x128/apps/kturtle.png
+share/icons/hicolor/16x16/apps/kturtle.png
+share/icons/hicolor/22x22/apps/kturtle.png
+share/icons/hicolor/32x32/apps/kturtle.png
+share/icons/hicolor/48x48/apps/kturtle.png
+share/icons/hicolor/64x64/apps/kturtle.png
+share/katepart/syntax/logohighlightstyle.en_GB.xml
+share/katepart/syntax/logohighlightstyle.nb.xml
+share/katepart/syntax/logohighlightstyle.nds.xml
+share/katepart/syntax/logohighlightstyle.nl.xml
+share/katepart/syntax/logohighlightstyle.ru.xml
+%%DATADIR%%/data/logokeywords.en_GB.xml
+%%DATADIR%%/data/logokeywords.nb.xml
+%%DATADIR%%/data/logokeywords.nl.xml
+%%DATADIR%%/examples/en_GB/curly.logo
+%%DATADIR%%/examples/en_GB/example1.logo
+%%DATADIR%%/examples/en_GB/square.logo
+%%DATADIR%%/examples/en_GB/triangle.logo
+%%DATADIR%%/examples/nb/arkfarge.logo
+%%DATADIR%%/examples/nb/blomst.logo
+%%DATADIR%%/examples/nb/gangetabell.logo
+%%DATADIR%%/examples/nb/kde.logo
+%%DATADIR%%/examples/nb/krusedull.logo
+%%DATADIR%%/examples/nb/kvadrat.logo
+%%DATADIR%%/examples/nb/kvadrathjul.logo
+%%DATADIR%%/examples/nb/pil.logo
+%%DATADIR%%/examples/nb/reklame.logo
+%%DATADIR%%/examples/nb/tilfeldige-navn.logo
+%%DATADIR%%/examples/nb/trekant.logo
+%%DATADIR%%/examples/nb/trekanthjul.logo
+%%DATADIR%%/examples/nds/bloom.logo
+%%DATADIR%%/examples/nds/dreeeck.logo
+%%DATADIR%%/examples/nds/dreeecks.logo
+%%DATADIR%%/examples/nds/eenmaaleen.logo
+%%DATADIR%%/examples/nds/kde.logo
+%%DATADIR%%/examples/nds/locken.logo
+%%DATADIR%%/examples/nds/niklaas.logo
+%%DATADIR%%/examples/nds/oeversicht_befehlen.logo
+%%DATADIR%%/examples/nds/piel.logo
+%%DATADIR%%/examples/nds/quadraat.logo
+%%DATADIR%%/examples/nds/quadraten.logo
+%%DATADIR%%/examples/nds/tofallnaam.logo
+%%DATADIR%%/examples/nds/wandkloeren.logo
+%%DATADIR%%/examples/nds/warf.logo
+%%DATADIR%%/examples/nl/advertentie.logo
+%%DATADIR%%/examples/nl/bloem.logo
+%%DATADIR%%/examples/nl/driehoek.logo
+%%DATADIR%%/examples/nl/driehoeken.logo
+%%DATADIR%%/examples/nl/kleuren.logo
+%%DATADIR%%/examples/nl/krullen.logo
+%%DATADIR%%/examples/nl/pijl.logo
+%%DATADIR%%/examples/nl/randomnaam.logo
+%%DATADIR%%/examples/nl/tafels.logo
+%%DATADIR%%/examples/nl/vierkant.logo
+%%DATADIR%%/examples/nl/vierkanten.logo
+share/kxmlgui5/kturtle/kturtleui.rc
+share/locale/ar/LC_MESSAGES/kturtle.mo
+share/locale/ast/LC_MESSAGES/kturtle.mo
+share/locale/bg/LC_MESSAGES/kturtle.mo
+share/locale/bs/LC_MESSAGES/kturtle.mo
+share/locale/ca/LC_MESSAGES/kturtle.mo
+share/locale/ca@valencia/LC_MESSAGES/kturtle.mo
+share/locale/cs/LC_MESSAGES/kturtle.mo
+share/locale/da/LC_MESSAGES/kturtle.mo
+share/locale/de/LC_MESSAGES/kturtle.mo
+share/locale/el/LC_MESSAGES/kturtle.mo
+share/locale/en_GB/LC_MESSAGES/kturtle.mo
+share/locale/eo/LC_MESSAGES/kturtle.mo
+share/locale/es/LC_MESSAGES/kturtle.mo
+share/locale/et/LC_MESSAGES/kturtle.mo
+share/locale/eu/LC_MESSAGES/kturtle.mo
+share/locale/fa/LC_MESSAGES/kturtle.mo
+share/locale/fi/LC_MESSAGES/kturtle.mo
+share/locale/fr/LC_MESSAGES/kturtle.mo
+share/locale/ga/LC_MESSAGES/kturtle.mo
+share/locale/gl/LC_MESSAGES/kturtle.mo
+share/locale/he/LC_MESSAGES/kturtle.mo
+share/locale/hi/LC_MESSAGES/kturtle.mo
+share/locale/hr/LC_MESSAGES/kturtle.mo
+share/locale/hu/LC_MESSAGES/kturtle.mo
+share/locale/it/LC_MESSAGES/kturtle.mo
+share/locale/ja/LC_MESSAGES/kturtle.mo
+share/locale/kk/LC_MESSAGES/kturtle.mo
+share/locale/km/LC_MESSAGES/kturtle.mo
+share/locale/lt/LC_MESSAGES/kturtle.mo
+share/locale/lv/LC_MESSAGES/kturtle.mo
+share/locale/mr/LC_MESSAGES/kturtle.mo
+share/locale/nb/LC_MESSAGES/kturtle.mo
+share/locale/nds/LC_MESSAGES/kturtle.mo
+share/locale/nl/LC_MESSAGES/kturtle.mo
+share/locale/nn/LC_MESSAGES/kturtle.mo
+share/locale/pa/LC_MESSAGES/kturtle.mo
+share/locale/pl/LC_MESSAGES/kturtle.mo
+share/locale/pt/LC_MESSAGES/kturtle.mo
+share/locale/pt_BR/LC_MESSAGES/kturtle.mo
+share/locale/ro/LC_MESSAGES/kturtle.mo
+share/locale/ru/LC_MESSAGES/kturtle.mo
+share/locale/sk/LC_MESSAGES/kturtle.mo
+share/locale/sl/LC_MESSAGES/kturtle.mo
+share/locale/sv/LC_MESSAGES/kturtle.mo
+share/locale/tr/LC_MESSAGES/kturtle.mo
+share/locale/ug/LC_MESSAGES/kturtle.mo
+share/locale/uk/LC_MESSAGES/kturtle.mo
+share/locale/zh_CN/LC_MESSAGES/kturtle.mo
+share/locale/zh_TW/LC_MESSAGES/kturtle.mo
+share/metainfo/org.kde.kturtle.appdata.xml