aboutsummaryrefslogtreecommitdiff
path: root/lang/libobjc2
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-26 11:35:56 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-26 11:35:56 +0000
commit933b3657a19b82e82077d7bffd61cae09f92124c (patch)
tree1bfcfd6ba1d951998555c1f51c19bb84078eff21 /lang/libobjc2
parent804b4d86966eb62aeff761b05b4075ccd4d9143d (diff)
downloadports-933b3657a19b82e82077d7bffd61cae09f92124c.tar.gz
ports-933b3657a19b82e82077d7bffd61cae09f92124c.zip
lang/libobjc2: fix build on powerpc* and riscv64*
Skip building tests on architectures that don't have assembly.
Diffstat (limited to 'lang/libobjc2')
-rw-r--r--lang/libobjc2/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/libobjc2/Makefile b/lang/libobjc2/Makefile
index de7744251c25..9f92390681f5 100644
--- a/lang/libobjc2/Makefile
+++ b/lang/libobjc2/Makefile
@@ -12,7 +12,6 @@ COMMENT= Replacement Objective-C runtime supporting modern Objective-C features
LICENSE= MIT
BROKEN_sparc64= Does not compile on sparc64: Cannot configure clang properly
-BROKEN_riscv64= Does not link on riscv64: undefined symbol: objc_msgSend
USES= cmake compiler objc:compiler
@@ -38,6 +37,10 @@ SHLIB_MINOR= 6
.include <bsd.port.pre.mk>
+.if ${ARCH:Mpowerpc*} || ${ARCH:Mriscv64*}
+CMAKE_ARGS+= -DTESTS:BOOL=OFF
+.endif
+
.if ${CHOSEN_COMPILER_TYPE} == gcc
CXXFLAGS+= -stdlib=libstdc++
.endif