aboutsummaryrefslogtreecommitdiff
path: root/lang/luajit/Makefile
diff options
context:
space:
mode:
authorSean Bruno <sbruno@FreeBSD.org>2015-05-02 18:43:35 +0000
committerSean Bruno <sbruno@FreeBSD.org>2015-05-02 18:43:35 +0000
commitc9dea4d2359c9f35e77f4abac949da81248b4160 (patch)
tree77f8e8b7417e8c50f8af9322b78c5aafd9cf8a13 /lang/luajit/Makefile
parentd607887cdb21a52711f1927631a966abc96b034c (diff)
downloadports-c9dea4d2359c9f35e77f4abac949da81248b4160.tar.gz
ports-c9dea4d2359c9f35e77f4abac949da81248b4160.zip
This time, don't delete the requisite includes for the post-install bits.
Reimplement ONLY_FOR_ARCHS such that we know that this port requires newer compiler features (which aren't very clear from the port itself). Probably need to validate this on powerpc as we have clang available and gcc ports. PR: 197132
Notes
Notes: svn path=/head/; revision=385203
Diffstat (limited to 'lang/luajit/Makefile')
-rw-r--r--lang/luajit/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/lang/luajit/Makefile b/lang/luajit/Makefile
index e902a368890e..fe41e4ae55b2 100644
--- a/lang/luajit/Makefile
+++ b/lang/luajit/Makefile
@@ -17,15 +17,14 @@ USE_LDCONFIG= yes
PLIST_SUB+= VERSION=${DISTVERSION}
+ONLY_FOR_ARCHS= i386 amd64 armv6
+ONLY_FOR_ARCHS_REASON= Requires newer gcc/clang to compile.
+
+.include <bsd.port.pre.mk>
+
post-install:
${LN} -sf ${PREFIX}/bin/${PORTNAME}-${DISTVERSION} \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}
@${INSTALL_MAN} ${WRKSRC}/etc/luajit.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
-
.include <bsd.port.post.mk>