aboutsummaryrefslogtreecommitdiff
path: root/lang/micropython
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-07-28 08:57:33 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-07-28 08:57:33 +0000
commit89e5af5da424bf80efff710ce55a53162c465a9a (patch)
tree82a2d5867433b01f00a87ffc3e5eeae48be843d4 /lang/micropython
parent1eeffbf93f0ad458edaf16940ee5bc32f26311b2 (diff)
downloadports-89e5af5da424bf80efff710ce55a53162c465a9a.tar.gz
ports-89e5af5da424bf80efff710ce55a53162c465a9a.zip
- Update to version 1.2
- Respect CFLAGS and CPPFLAGS
Notes
Notes: svn path=/head/; revision=363122
Diffstat (limited to 'lang/micropython')
-rw-r--r--lang/micropython/Makefile11
-rw-r--r--lang/micropython/distinfo4
-rw-r--r--lang/micropython/files/patch-builtinimport.c14
-rw-r--r--lang/micropython/files/patch-modtime.c11
-rw-r--r--lang/micropython/files/patch-objfun.c14
-rw-r--r--lang/micropython/files/patch-runtime.c14
6 files changed, 8 insertions, 60 deletions
diff --git a/lang/micropython/Makefile b/lang/micropython/Makefile
index 0fa471add4e2..4ba0a5f420ff 100644
--- a/lang/micropython/Makefile
+++ b/lang/micropython/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= micropython
-PORTVERSION= 1.0.1
+PORTVERSION= 1.2
CATEGORIES= lang python
MAINTAINER= mva@FreeBSD.org
@@ -17,8 +17,8 @@ USES= gmake shebangfix pkgconfig readline
USE_GITHUB= yes
GH_ACCOUNT= micropython
GH_PROJECT= micropython
-GH_TAGNAME= v1.0.1
-GH_COMMIT= a56f31d
+GH_TAGNAME= v1.2
+GH_COMMIT= d94863d
PLIST_FILES= bin/micropython
@@ -27,10 +27,11 @@ WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}/unix
SHEBANG_FILES= ../py/py-version.sh
bash_CMD?= /bin/sh
MAKE_ARGS+= V=1
-MAKE_ENV+= PYTHON=${PYTHON_CMD}
+MAKE_ENV+= PYTHON=${PYTHON_CMD} CFLAGS_EXTRA="${CPPFLAGS} ${CFLAGS}"
post-patch:
- @${REINPLACE_CMD} -e 's|-Werror||;s|-ldl||' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-Wno-error=cpp||;s|-Werror||;/^COPT =/d' \
+ ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|AS =|AS ?=|;s|LD =|LD ?=|; \
s|CC =|CC ?=|;s|PYTHON =|PYTHON ?=|' \
${WRKSRC}/../py/mkenv.mk
diff --git a/lang/micropython/distinfo b/lang/micropython/distinfo
index 230f91b5e5d4..083665805d39 100644
--- a/lang/micropython/distinfo
+++ b/lang/micropython/distinfo
@@ -1,2 +1,2 @@
-SHA256 (micropython-1.0.1.tar.gz) = 6fcd4e7987a9691025c24d1b2c2946ff0d7fb912f3869dfcee52143dfbd8a4e2
-SIZE (micropython-1.0.1.tar.gz) = 4693643
+SHA256 (micropython-1.2.tar.gz) = 45220badf244817ab8e04941e3fb4a49d5b8748190e3ee7eeb2b0e8bfd6a7fb8
+SIZE (micropython-1.2.tar.gz) = 4170808
diff --git a/lang/micropython/files/patch-builtinimport.c b/lang/micropython/files/patch-builtinimport.c
deleted file mode 100644
index b88a23b5d958..000000000000
--- a/lang/micropython/files/patch-builtinimport.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ../py/builtinimport.c.orig 2014-06-05 06:09:16.000000000 +0200
-+++ ../py/builtinimport.c 2014-06-05 06:09:56.000000000 +0200
-@@ -28,7 +28,11 @@
- #include <stdio.h>
- #include <string.h>
- #include <assert.h>
-+#ifndef __FreeBSD__
- #include <alloca.h>
-+#else
-+#include <stdlib.h>
-+#endif
-
- #include "mpconfig.h"
- #include "nlr.h"
diff --git a/lang/micropython/files/patch-modtime.c b/lang/micropython/files/patch-modtime.c
deleted file mode 100644
index 0a8fd1312463..000000000000
--- a/lang/micropython/files/patch-modtime.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- modtime.c.orig 2014-06-05 20:07:38.000000000 +0200
-+++ modtime.c 2014-06-06 07:58:58.000000000 +0200
-@@ -59,6 +59,8 @@
- #define CLOCK_DIV 1000.0
- #elif defined(MP_CLOCKS_PER_SEC) && (MP_CLOCKS_PER_SEC == 1000) // WIN32
- #define CLOCK_DIV 1.0
-+#elif defined(__FreeBSD__) && (MP_CLOCKS_PER_SEC == 128)
-+#define CLOCK_DIV (1.0 / 128.0)
- #else
- #error Unsupported clock() implementation
- #endif
diff --git a/lang/micropython/files/patch-objfun.c b/lang/micropython/files/patch-objfun.c
deleted file mode 100644
index fe0ee281fd9e..000000000000
--- a/lang/micropython/files/patch-objfun.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ../py/objfun.c.orig 2014-06-04 22:09:47.000000000 +0200
-+++ ../py/objfun.c 2014-06-04 22:10:16.000000000 +0200
-@@ -27,7 +27,11 @@
- #include <stdbool.h>
- #include <string.h>
- #include <assert.h>
-+#ifndef __FreeBSD__
- #include <alloca.h>
-+#else
-+#include <stdlib.h>
-+#endif
-
- #include "mpconfig.h"
- #include "nlr.h"
diff --git a/lang/micropython/files/patch-runtime.c b/lang/micropython/files/patch-runtime.c
deleted file mode 100644
index 264f57ecc377..000000000000
--- a/lang/micropython/files/patch-runtime.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ../py/runtime.c.orig 2014-06-04 22:05:32.000000000 +0200
-+++ ../py/runtime.c 2014-06-04 22:06:16.000000000 +0200
-@@ -27,7 +27,11 @@
- #include <stdio.h>
- #include <string.h>
- #include <assert.h>
-+#ifndef __FreeBSD__
- #include <alloca.h>
-+#else
-+#include <stdlib.h> /* alloca() */
-+#endif
-
- #include "mpconfig.h"
- #include "nlr.h"