aboutsummaryrefslogtreecommitdiff
path: root/lang/modula-3/Makefile
diff options
context:
space:
mode:
authorJohn Polstra <jdp@FreeBSD.org>1997-07-26 00:24:53 +0000
committerJohn Polstra <jdp@FreeBSD.org>1997-07-26 00:24:53 +0000
commit3823b5b7fda687ec9a668d30d5fc98c3621e2b73 (patch)
treeee9bf146efcd5ce7be8591b8e19cc2e826174af6 /lang/modula-3/Makefile
parent5530145551a089b285445a1b73df57a9aaa138f2 (diff)
downloadports-3823b5b7fda687ec9a668d30d5fc98c3621e2b73.tar.gz
ports-3823b5b7fda687ec9a668d30d5fc98c3621e2b73.zip
Use the MAN1 macro to compress the manual pages.
Correct the "fixing file permissions" step so that it works when NOMANCOMPRESS is set.
Notes
Notes: svn path=/head/; revision=7415
Diffstat (limited to 'lang/modula-3/Makefile')
-rw-r--r--lang/modula-3/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/lang/modula-3/Makefile b/lang/modula-3/Makefile
index adfb00ce9990..7ee5483244d6 100644
--- a/lang/modula-3/Makefile
+++ b/lang/modula-3/Makefile
@@ -3,7 +3,7 @@
# Date created: 18 Mar 1996
# Whom: John Polstra <jdp@polstra.com>
#
-# $Id: Makefile,v 1.16 1997/07/13 18:49:21 max Exp $
+# $Id: Makefile,v 1.17 1997/07/17 15:12:48 max Exp $
#
DISTNAME= modula-3-3.6
@@ -18,6 +18,10 @@ WRKSRC= ${PORTSDIR}/lang/modula-3-lib/work
NO_CHECKSUM= yes
NO_CONFIGURE= yes
NO_BUILD= yes
+MAN1= analyze_coverage.1 formsedit.1 m3browser.1 \
+ m3build.1 m3bundle.1 m3pp.1 m3ship.1 m3tohtml.1 \
+ m3totex.1 m3where.1 quake.1 recordheap.1 \
+ replayheap.1 showheap.1 shownew.1 showthread.1
# Keep these in sync with the PLIST and with the library version numbers
# in the modula-3-lib port.
@@ -81,15 +85,12 @@ do-install:
@cd ${PREFIX}/bin; \
ln -f m3build m3build-${major}; \
ln -f m3build m3build-${major}.${minor}
-.if !defined(NOMANCOMPRESS)
- @echo "Compressing manual pages"
- @cd ${temp_prefix}; \
- find man -type f | (cd ${PREFIX}; xargs gzip -9nf)
-.endif
@echo "Fixing file permissions"
@cd ${PREFIX}; \
- grep -v "^@" ${PKGDIR}/PLIST | xargs chown ${BINOWN}.${BINGRP}; \
- grep -v "^@" ${PKGDIR}/PLIST | xargs chmod go=u-w; \
+ sed -e "/^@/d" -e "s/\.gz$$//" ${PKGDIR}/PLIST |\
+ xargs chown ${BINOWN}.${BINGRP}; \
+ sed -e "/^@/d" -e "s/\.gz$$//" ${PKGDIR}/PLIST |\
+ xargs chmod go=u-w; \
find -X lib/m3 -type d | xargs chown ${BINOWN}.${BINGRP}; \
find -X lib/m3 -type d | xargs chmod 755
@echo "Running ldconfig"