aboutsummaryrefslogtreecommitdiff
path: root/lang/mono
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2011-09-21 17:52:24 +0000
committerRomain Tartière <romain@FreeBSD.org>2011-09-21 17:52:24 +0000
commite8f7b76b35093265365f7604596e5028ae8ccc0e (patch)
tree027c0851467b708f879cf15a7d5e25efd51e956c /lang/mono
parent2969b6fd2de1ff4ba74c6caa98bffad812a79cd1 (diff)
downloadports-e8f7b76b35093265365f7604596e5028ae8ccc0e.tar.gz
ports-e8f7b76b35093265365f7604596e5028ae8ccc0e.zip
Update to 2.10.5.
Notes
Notes: svn path=/head/; revision=282140
Diffstat (limited to 'lang/mono')
-rw-r--r--lang/mono/Makefile6
-rw-r--r--lang/mono/distinfo4
-rw-r--r--lang/mono/files/patch-mono_utils_mono-sigcontext.h16
3 files changed, 21 insertions, 5 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 7ffa6f7d8aef..cb7dffa7692c 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= mono
-PORTVERSION= 2.10.2
+PORTVERSION= 2.10.5
CATEGORIES= lang
-MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
+MASTER_SITES= http://download.mono-project.com/sources/${PORTNAME}/
MAINTAINER= mono@FreeBSD.org
COMMENT= An open source implementation of .NET Development Framework
@@ -75,5 +75,5 @@ post-configure:
@${REINPLACE_CMD} -e 's|share\/man|man|g' \
${WRKSRC}/mcs/jay/Makefile
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+.include "${PORTSDIR}/lang/mono/bsd.mono.mk"
.include <bsd.port.post.mk>
diff --git a/lang/mono/distinfo b/lang/mono/distinfo
index f0bd7d0ec39c..861fb7984a69 100644
--- a/lang/mono/distinfo
+++ b/lang/mono/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mono-2.10.2.tar.bz2) = 9614472aa131e61bcdbf2fc48ab7a123ea57a10e736def5136a478465afa06b4
-SIZE (mono-2.10.2.tar.bz2) = 33737282
+SHA256 (mono-2.10.5.tar.bz2) = a80c644862541f403f8d51a3b7c71c47b6567614884639c2d890e27fa9efaf16
+SIZE (mono-2.10.5.tar.bz2) = 33940775
diff --git a/lang/mono/files/patch-mono_utils_mono-sigcontext.h b/lang/mono/files/patch-mono_utils_mono-sigcontext.h
new file mode 100644
index 000000000000..88a6b8070b3f
--- /dev/null
+++ b/lang/mono/files/patch-mono_utils_mono-sigcontext.h
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- mono/utils/mono-sigcontext.h.orig
++++ mono/utils/mono-sigcontext.h
+@@ -109,6 +109,10 @@
+ #define UCONTEXT_REG_RSI(ctx) (((ucontext_t*)(ctx))->uc_mcontext.mc_rsi)
+ #define UCONTEXT_REG_RDI(ctx) (((ucontext_t*)(ctx))->uc_mcontext.mc_rdi)
+ #define UCONTEXT_REG_RIP(ctx) (((ucontext_t*)(ctx))->uc_mcontext.mc_rip)
++ #define UCONTEXT_REG_R8(ctx) (((ucontext_t*)(ctx))->uc_mcontext.mc_r8)
++ #define UCONTEXT_REG_R9(ctx) (((ucontext_t*)(ctx))->uc_mcontext.mc_r9)
++ #define UCONTEXT_REG_R10(ctx) (((ucontext_t*)(ctx))->uc_mcontext.mc_r10)
++ #define UCONTEXT_REG_R11(ctx) (((ucontext_t*)(ctx))->uc_mcontext.mc_r11)
+ #define UCONTEXT_REG_R12(ctx) (((ucontext_t*)(ctx))->uc_mcontext.mc_r12)
+ #define UCONTEXT_REG_R13(ctx) (((ucontext_t*)(ctx))->uc_mcontext.mc_r13)
+ #define UCONTEXT_REG_R14(ctx) (((ucontext_t*)(ctx))->uc_mcontext.mc_r14)