aboutsummaryrefslogtreecommitdiff
path: root/lang/moscow_ml/Makefile
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2002-05-30 10:47:57 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2002-05-30 10:47:57 +0000
commitdcd902f84652155189b05b0e4abe32bc2a8237ad (patch)
tree2e8b4a5c8f29b87e6704f9102917bddf02be03ba /lang/moscow_ml/Makefile
parent05ff8debcd47d119bdc1ab2d96f0a9ca34cbfe84 (diff)
downloadports-dcd902f84652155189b05b0e4abe32bc2a8237ad.tar.gz
ports-dcd902f84652155189b05b0e4abe32bc2a8237ad.zip
Upgrade to v2.0.
Submitted by: Johannes 5 Joemann <joemann@beefree.free.de>
Notes
Notes: svn path=/head/; revision=60279
Diffstat (limited to 'lang/moscow_ml/Makefile')
-rw-r--r--lang/moscow_ml/Makefile46
1 files changed, 19 insertions, 27 deletions
diff --git a/lang/moscow_ml/Makefile b/lang/moscow_ml/Makefile
index 8e9708680afe..528a83bc93b5 100644
--- a/lang/moscow_ml/Makefile
+++ b/lang/moscow_ml/Makefile
@@ -6,40 +6,32 @@
#
PORTNAME= moscow_ml
-PORTVERSION= 1.4
+PORTVERSION= 2.00
CATEGORIES= lang
MASTER_SITES= ftp://ftp.dina.kvl.dk/pub/mosml/ \
- ftp://ftp.csd.uu.se/pub/mirror/mosml/ \
- ftp://ftp.dcs.ed.ac.uk/pub/ml/Moscow/
-DISTNAME= mos14src
+ ftp://ftp.csd.uu.se/pub/mirror/mosml/
+DISTNAME= mos20src
MAINTAINER= chuckr@freefall.FreeBSD.org
-ALL_TARGET= world MOSMLHOME=$(PREFIX)/moscow_ml
-INSTALL_TARGET= install MOSMLHOME=$(PREFIX)/moscow_ml
+MOSMLHOME= $(PREFIX)/moscow_ml
+
+ALL_TARGET= world MOSMLHOME=$(MOSMLHOME)
+INSTALL_TARGET= install MOSMLHOME=$(MOSMLHOME)
WRKSRC= ${WRKDIR}/mosml/src
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/moscow_ml/doc
- ${MKDIR} ${PREFIX}/moscow_ml/doc/mosmllib
- ${MKDIR} ${PREFIX}/moscow_ml/examples
- for file in ${WRKDIR}/mosml/doc/*;do \
- if [ -f $${file} ]; then\
- ${INSTALL_DATA} $${file} ${PREFIX}/moscow_ml/doc;fi;done
- for file in ${WRKDIR}/mosml/doc/mosmllib/*;do \
- ${INSTALL_DATA} $${file} ${PREFIX}/moscow_ml/doc/mosmllib;done
- (cd ${WRKDIR}/mosml/examples; \
- ${INSTALL_DATA} README ${PREFIX}/moscow_ml/examples; \
- for sdirs in manual mls helpsigs calc pretty lexyacc;do \
- ${MKDIR} ${PREFIX}/moscow_ml/examples/$${sdirs}; \
- for file in $${sdirs}/*;do \
- if [ -f $${file} ]; then\
- ${INSTALL_DATA} $${file} ${PREFIX}/moscow_ml/examples/$${sdirs}; fi; \
- done; done;)
-.endif
- for file in $(PREFIX)/moscow_ml/bin/*;do \
- if [ -f $${file} ]; then\
- $(LN) -sf $${file} $(PREFIX)/bin;fi;done
+ ${SED} -e 's|^MOSMLHOME=.*|MOSMLHOME=${MOSMLHOME}|' \
+ ${WRKDIR}/mosml/tools/Makefile.stub > ${MOSMLHOME}/tools/Makefile.stub
+ for file in ${WRKDIR}/mosml/doc/*; do \
+ if [ -f $${file} ]; then \
+ ${INSTALL_DATA} $${file} ${MOSMLHOME}/doc; fi; done
+ @cd ${WRKDIR}/mosml && \
+ ${TAR} -cf - examples | \
+ ${TAR} -xf - -C "${MOSMLHOME}"
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} "${MOSMLHOME}/examples"
+ for file in ${MOSMLHOME}/bin/*; do \
+ if [ -f $${file} ]; then \
+ $(LN) -sf $${file} $(PREFIX)/bin; fi; done
.include <bsd.port.mk>