aboutsummaryrefslogtreecommitdiff
path: root/lang/mujs
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-11-12 02:53:11 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-11-12 02:53:11 +0000
commit75777eba40ec30d0b39ee68f4e5f67d62823f451 (patch)
tree3e5535d6a277909fe3720480cfddaadc94eeb04d /lang/mujs
parent04c77ece4708985c2464b5ca6a015b85d4c291c7 (diff)
downloadports-75777eba40ec30d0b39ee68f4e5f67d62823f451.tar.gz
ports-75777eba40ec30d0b39ee68f4e5f67d62823f451.zip
lang/mujs: Enable the static library; Strip the shared library.
Notes
Notes: svn path=/head/; revision=517301
Diffstat (limited to 'lang/mujs')
-rw-r--r--lang/mujs/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/mujs/Makefile b/lang/mujs/Makefile
index ba2241371377..65521758ae06 100644
--- a/lang/mujs/Makefile
+++ b/lang/mujs/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mujs
DISTVERSION= 1.0.6
+PORTREVISION= 1
CATEGORIES= lang devel
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
@@ -17,8 +18,8 @@ USES= compiler:c11 gmake readline # c11 is induced by the FreeBSD headers via i
USE_GITHUB= yes
GH_ACCOUNT= ccxvii
USE_LDCONFIG= yes
-ALL_TARGET= shared
-INSTALL_TARGET= install-shared
+ALL_TARGET= shared static
+INSTALL_TARGET= install-shared install-static
.if defined(WITH_DEBUG) # this project manages its build options itself
MAKE_ARGS= build=debug
@@ -27,6 +28,10 @@ MAKE_ARGS= build=debug
PLIST_FILES= bin/mujs \
include/mujs.h \
lib/libmujs.so \
+ lib/libmujs.a \
libdata/pkgconfig/mujs.pc
+post-install: # https://github.com/ccxvii/mujs/issues/99
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmujs.so
+
.include <bsd.port.mk>