aboutsummaryrefslogtreecommitdiff
path: root/lang/nhc98/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-07-01 14:14:03 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-07-01 14:14:03 +0000
commit844d0d223738dad3170fccd39866ab4eba42ceec (patch)
tree3b44662fe108c41b07c82a9fb6f402b09e412bb2 /lang/nhc98/Makefile
parentfe8cff9a51bdafedd43f9dcd211fce2e16b86e80 (diff)
downloadports-844d0d223738dad3170fccd39866ab4eba42ceec.tar.gz
ports-844d0d223738dad3170fccd39866ab4eba42ceec.zip
- Update to 1.22
- Stagify - Introduce explicit dependency on GCC to make it build on 10.x and later - Remove indefinite article from COMMENT - Mark jobs unsafe as it does not build reliably on multi-core systems - Remove hmake from conflicting packages, it is long gone - Rework handling of documentation - Update master site Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=360014
Diffstat (limited to 'lang/nhc98/Makefile')
-rw-r--r--lang/nhc98/Makefile45
1 files changed, 14 insertions, 31 deletions
diff --git a/lang/nhc98/Makefile b/lang/nhc98/Makefile
index 37f073c34e7c..629a792c4ebf 100644
--- a/lang/nhc98/Makefile
+++ b/lang/nhc98/Makefile
@@ -2,41 +2,35 @@
# $FreeBSD$
PORTNAME= nhc98
-PORTVERSION= 1.18
-PORTREVISION= 2
+PORTVERSION= 1.22
CATEGORIES= lang haskell
-MASTER_SITES= ftp://ftp.cs.york.ac.uk/pub/haskell/${PORTNAME}/
-DISTFILES= ${PORTNAME}src-${PORTVERSION}${EXTRACT_SUFX} ${PORTNAME}-${PORTVERSION}-library-interfaces${EXTRACT_SUFX}
+MASTER_SITES= http://haskell.org/${PORTNAME}/
+DISTFILES= ${PORTNAME}src-${PORTVERSION}${EXTRACT_SUFX}
DIST_SUBDIR= nhc98
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= patch-1.18-newtype
MAINTAINER= haskell@FreeBSD.org
-COMMENT= A fully-fledged compiler for Haskell 98
+COMMENT= Fully-fledged compiler for Haskell 98
ONLY_FOR_ARCHS= i386
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= gmake
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--prefix=${PREFIX} --buildwith=gcc
+USE_GCC= yes
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX} --heap=4M
+MAKE_ARGS+= ARCH=
+MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= DOCS
OPTIONS_DEFAULT= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-CONFIGURE_ARGS+= --docdir=${DOCSDIR} +docs
-.else
-CONFIGURE_ARGS+= -docs
-.endif
+DOCS_CONFIGURE_ON= --docdir=${DOCSDIR} +docs
+DOCS_CONFIGURE_OFF= -docs
-MAN1= harch.1 hmake.1 hp2graph.1 nhc98.1 hi.1
-
-CONFLICTS= hs-hmake-[0-9]* hs-cpphs-[0-9]*
+PORTDOCS= *
+CONFLICTS= hs-cpphs-[0-9]*
post-patch:
@${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
@@ -46,15 +40,4 @@ post-configure:
@${ECHO} "LIBDIR=${PREFIX}/lib/nhc98" \
>> ${WRKSRC}/targets/ix86-FreeBSD/config.cache
-post-install:
- ${SED} -e "s#/usr/doc/nhc98#${PREFIX}/share/doc/nhc98#" \
- < ${WRKSRC}/man/nhc98.1 > ${WRKSRC}/man/nhc98.1.fix
- ${INSTALL_MAN} ${WRKSRC}/man/nhc98.1.fix ${PREFIX}/man/man1/nhc98.1
- ${RM} ${WRKSRC}/man/nhc98.1.fix
-.if ${PORT_OPTIONS:MDOCS}
-.for directory in . bugs examples hmake implementation-notes libs
- ${RM} -r ${DOCSDIR}/${directory}/CVS
-.endfor
-.endif
-
.include <bsd.port.mk>