aboutsummaryrefslogtreecommitdiff
path: root/lang/nhc98/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2005-03-17 22:01:46 +0000
committerOliver Braun <obraun@FreeBSD.org>2005-03-17 22:01:46 +0000
commitb73fc2418f099a5124605813e529913656f04de2 (patch)
tree4dd20154d9987bc8d63af88246e0f0b4dd50806d /lang/nhc98/Makefile
parentd29f3ee5ba0703255d7073f15f99fbb0ff530c7b (diff)
downloadports-b73fc2418f099a5124605813e529913656f04de2.tar.gz
ports-b73fc2418f099a5124605813e529913656f04de2.zip
* Upgrade to 1.18.
* Remove BROKEN.
Notes
Notes: svn path=/head/; revision=131531
Diffstat (limited to 'lang/nhc98/Makefile')
-rw-r--r--lang/nhc98/Makefile33
1 files changed, 6 insertions, 27 deletions
diff --git a/lang/nhc98/Makefile b/lang/nhc98/Makefile
index 2647dced3b02..e8dcb18db744 100644
--- a/lang/nhc98/Makefile
+++ b/lang/nhc98/Makefile
@@ -5,17 +5,12 @@
# $FreeBSD$
PORTNAME= nhc98
-PORTVERSION= 1.16
-PORTREVISION= 2
+PORTVERSION= 1.18
CATEGORIES= lang haskell
MASTER_SITES= ftp://ftp.cs.york.ac.uk/pub/haskell/${PORTNAME}/
DISTNAME= ${PORTNAME}src-${PORTVERSION}
DIST_SUBDIR= nhc98
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= patch-1.16-typesyn \
- patch-1.16-ghc6
-
MAINTAINER= haskell@FreeBSD.org
COMMENT= A fully-fledged compiler for Haskell 98
@@ -23,39 +18,23 @@ ONLY_FOR_ARCHS= i386
USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502102
-BROKEN= "Does not compile"
-.endif
-
-.if ${OSVERSION} >= 500000
-BUILD_DEPENDS+= ghc-5.04.3:${PORTSDIR}/lang/ghc5
-.endif
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
HAS_CONFIGURE= yes
-
-.if ${OSVERSION} >= 500000
-CONFIGURE_ARGS+= --buildwith=ghc
-.endif
+CONFIGURE_ARGS+= --buildwith=gcc
.if !defined(NOPORTDOCS)
CONFIGURE_ARGS+= --docdir=${DOCSDIR} +docs
.endif
-MAN1= harch.1 hmake.1 hp2graph.1 nhc98.1
+MAN1= harch.1 hmake.1 hp2graph.1 nhc98.1 hi.1
-CONFLICTS= hs-hmake-*
+CONFLICTS= hs-hmake-[0-9]* hs-cpphs-[0-9]*
post-patch:
@${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
-.for file in Decl FillIn Process
- @${REINPLACE_CMD} -e '/^import PrelBase/d' \
- ${WRKSRC}/src/greencard/${file}.lhs
-.endfor
+ @${REINPLACE_CMD} -e 's|$$(CC)|gcc|g' ${WRKSRC}/Makefile
post-configure:
@${ECHO} "LIBDIR=${PREFIX}/lib/nhc98" \
@@ -72,4 +51,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>