aboutsummaryrefslogtreecommitdiff
path: root/lang/nim
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-11-03 12:18:03 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-11-03 12:18:03 +0000
commit4f3529bae779ea7b5c7978f57933852843e8bf51 (patch)
tree51ab87b17372100e3096fe449d1900ca208fb8a6 /lang/nim
parent89c8d3a6fe2ceb02fb818399de2eea057650d34b (diff)
downloadports-4f3529bae779ea7b5c7978f57933852843e8bf51.tar.gz
ports-4f3529bae779ea7b5c7978f57933852843e8bf51.zip
lang/nim: Update to 1.4.0
- Update to 1.4.0 - Add a workaround to build doc in poudriere - Remove patch-compiler_docgen.nim (fixed upstream) - Add patch-koch.nim to disable Fusion build Release notes: - https://nim-lang.org/blog/2020/10/16/version-140-released.html PR: 250458 Submitted by: Neal Nelson (maintainer)
Notes
Notes: svn path=/head/; revision=553979
Diffstat (limited to 'lang/nim')
-rw-r--r--lang/nim/Makefile17
-rw-r--r--lang/nim/distinfo6
-rw-r--r--lang/nim/files/patch-compiler_docgen.nim11
-rw-r--r--lang/nim/files/patch-config-nim.cfg13
-rw-r--r--lang/nim/files/patch-koch.nim11
-rw-r--r--lang/nim/pkg-plist172
6 files changed, 204 insertions, 26 deletions
diff --git a/lang/nim/Makefile b/lang/nim/Makefile
index 075c0539102c..41e6ff4e16e0 100644
--- a/lang/nim/Makefile
+++ b/lang/nim/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nim
-PORTVERSION= 1.2.6
-PORTREVISION= 1
+PORTVERSION= 1.4.0
CATEGORIES= lang
MASTER_SITES= https://nim-lang.org/download/
@@ -13,9 +12,10 @@ COMMENT= Nim programming language
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/copying.txt
-BROKEN_mips64= fails to build: build.sh: clang: not found
BROKEN_sparc64= fails to build: build.sh: clang: not found
+LIB_DEPENDS= libpcre.so:devel/pcre
+
TEST_DEPENDS= node>=0:www/node
USES= compiler:c11 tar:xz
@@ -61,11 +61,19 @@ do-build:
-d:release --nimcache=${WRKDIR}/nimcache --app:lib \
-d:createNimRtl lib/nimrtl.nim
+do-build-DOCS-on:
+ cd ${WRKSRC} && ./koch --localdocs docs \
+ -d:release --nimcache=${WRKDIR}/nimcache --docCmd=skip
+
do-build-TOOLS-on:
cd ${WRKSRC} && ./koch toolsNoNimble --parallelBuild=${MAKE_JOBS_NUMBER} \
- -d:release --nimcache=${WRKDIR}/nimcache
+ -d:release --nimcache=${WRKSRC}/nimcache
+
do-install:
+ # Revert hack to build docs
+ @${REINPLACE_CMD} -e '/%%NIMCACHE%%/d' \
+ ${WRKSRC}/config/nim.cfg
# Install nim compiler
${INSTALL_PROGRAM} ${WRKSRC}/bin/nim ${STAGEDIR}${PREFIX}/bin
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/nim
@@ -83,6 +91,7 @@ do-install:
.endfor
do-install-DOCS-on:
+ ${FIND} ${WRKSRC}/doc -name "*.idx" -delete
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
diff --git a/lang/nim/distinfo b/lang/nim/distinfo
index d4cd43ca5ca1..8981b6f17d15 100644
--- a/lang/nim/distinfo
+++ b/lang/nim/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1596188944
-SHA256 (nim-1.2.6.tar.xz) = df88ea712e96ea847b610d56ef69f46ba587002052a46bf03c5c62affac7657e
-SIZE (nim-1.2.6.tar.xz) = 5688752
+TIMESTAMP = 1603099030
+SHA256 (nim-1.4.0.tar.xz) = be3120ab6b737f6ce0dd63fabf9e7c2c7625992b1145e5ebccf0573f3b09905d
+SIZE (nim-1.4.0.tar.xz) = 4626604
diff --git a/lang/nim/files/patch-compiler_docgen.nim b/lang/nim/files/patch-compiler_docgen.nim
deleted file mode 100644
index edac356dbad6..000000000000
--- a/lang/nim/files/patch-compiler_docgen.nim
+++ /dev/null
@@ -1,11 +0,0 @@
---- compiler/docgen.nim.orig 2020-08-21 12:50:46 UTC
-+++ compiler/docgen.nim
-@@ -1163,7 +1163,7 @@ proc writeOutput*(d: PDoc, useWarning = false) =
- rawMessage(d.conf, if useWarning: warnCannotOpenFile else: errCannotOpenFile,
- outfile.string)
- elif not d.wroteCss:
-- let cssSource = $d.conf.getPrefixDir() / "doc" / "nimdoc.css"
-+ let cssSource = $d.conf.getPrefixDir() / "share/doc/nim" / "nimdoc.css"
- let cssDest = $dir / nimdocOutCss
- copyFile(cssSource, cssDest)
- d.wroteCss = true
diff --git a/lang/nim/files/patch-config-nim.cfg b/lang/nim/files/patch-config-nim.cfg
index 041aa490c3c7..2c2a4e7cbd5b 100644
--- a/lang/nim/files/patch-config-nim.cfg
+++ b/lang/nim/files/patch-config-nim.cfg
@@ -1,6 +1,15 @@
---- config/nim.cfg.orig 2020-09-15 13:59:31 UTC
+--- config/nim.cfg.orig 2020-10-25 07:25:40 UTC
+++ config/nim.cfg
-@@ -118,12 +119,6 @@ path="$lib/pure"
+@@ -10,6 +10,8 @@
+
+ cc = clang
+
++nimcache="%%NIMCACHE%%"
++
+ # additional options always passed to the compiler:
+ --parallel_build: "0" # 0 to auto-detect number of processors
+
+@@ -118,12 +120,6 @@ path="$lib/pure"
clang.options.linker = "-ldl"
clang.cpp.options.linker = "-ldl"
tcc.options.linker = "-ldl"
diff --git a/lang/nim/files/patch-koch.nim b/lang/nim/files/patch-koch.nim
new file mode 100644
index 000000000000..8f15bb1142d9
--- /dev/null
+++ b/lang/nim/files/patch-koch.nim
@@ -0,0 +1,11 @@
+--- koch.nim.orig 2020-11-03 05:15:11 UTC
++++ koch.nim
+@@ -687,7 +687,7 @@ when isMainModule:
+ of "tools":
+ buildTools(op.cmdLineRest)
+ bundleNimbleExe(latest, op.cmdLineRest)
+- bundleFusion(latest)
++ # bundleFusion(latest)
+ of "pushcsource", "pushcsources": pushCsources()
+ of "valgrind": valgrind(op.cmdLineRest)
+ of "c2nim": bundleC2nim(op.cmdLineRest)
diff --git a/lang/nim/pkg-plist b/lang/nim/pkg-plist
index 55a9cde387b2..aa2205c6b401 100644
--- a/lang/nim/pkg-plist
+++ b/lang/nim/pkg-plist
@@ -45,7 +45,6 @@ lib/nim/compiler/evaltempl.nim
lib/nim/compiler/extccomp.nim
lib/nim/compiler/filter_tmpl.nim
lib/nim/compiler/filters.nim
-lib/nim/compiler/forloops.nim
lib/nim/compiler/gorgeimpl.nim
lib/nim/compiler/guards.nim
lib/nim/compiler/hlo.nim
@@ -53,9 +52,11 @@ lib/nim/compiler/idents.nim
lib/nim/compiler/idgen.nim
lib/nim/compiler/importer.nim
lib/nim/compiler/incremental.nim
+lib/nim/compiler/index.nim
lib/nim/compiler/injectdestructors.nim
lib/nim/compiler/installer.ini
lib/nim/compiler/int128.nim
+lib/nim/compiler/isolation_check.nim
lib/nim/compiler/jsgen.nim
lib/nim/compiler/jstypes.nim
lib/nim/compiler/lambdalifting.nim
@@ -86,9 +87,11 @@ lib/nim/compiler/nimfix/nimfix.nim
lib/nim/compiler/nimfix/nimfix.nim.cfg
lib/nim/compiler/nimfix/prettybase.nim
lib/nim/compiler/nimlexbase.nim
+lib/nim/compiler/nimpaths.nim
lib/nim/compiler/nimsets.nim
lib/nim/compiler/nodejs.nim
lib/nim/compiler/nversion.nim
+lib/nim/compiler/optimizer.nim
lib/nim/compiler/options.nim
lib/nim/compiler/packagehandling.nim
lib/nim/compiler/parampatterns.nim
@@ -105,8 +108,9 @@ lib/nim/compiler/pluginsupport.nim
lib/nim/compiler/pragmas.nim
lib/nim/compiler/prefixmatches.nim
lib/nim/compiler/procfind.nim
-lib/nim/compiler/readme.txt
+lib/nim/compiler/readme.md
lib/nim/compiler/renderer.nim
+lib/nim/compiler/renderverbatim.nim
lib/nim/compiler/reorder.nim
lib/nim/compiler/rod.nim
lib/nim/compiler/rodimpl.nim
@@ -137,24 +141,27 @@ lib/nim/compiler/sinkparameter_inference.nim
lib/nim/compiler/sizealignoffsetimpl.nim
lib/nim/compiler/sourcemap.nim
lib/nim/compiler/spawn.nim
+lib/nim/compiler/strutils2.nim
lib/nim/compiler/suggest.nim
lib/nim/compiler/syntaxes.nim
lib/nim/compiler/tccgen.nim
lib/nim/compiler/transf.nim
lib/nim/compiler/trees.nim
lib/nim/compiler/treetab.nim
+lib/nim/compiler/typeallowed.nim
lib/nim/compiler/types.nim
lib/nim/compiler/typesrenderer.nim
-lib/nim/compiler/unittest_light.nim
+lib/nim/compiler/varpartitions.nim
lib/nim/compiler/vm.nim
+lib/nim/compiler/vmconv.nim
lib/nim/compiler/vmdef.nim
lib/nim/compiler/vmdeps.nim
lib/nim/compiler/vmgen.nim
lib/nim/compiler/vmhooks.nim
lib/nim/compiler/vmmarshal.nim
lib/nim/compiler/vmops.nim
+lib/nim/compiler/vmprofiler.nim
lib/nim/compiler/wordrecg.nim
-lib/nim/compiler/writetracking.nim
lib/nim/core/hotcodereloading.nim
lib/nim/core/locks.nim
lib/nim/core/macrocache.nim
@@ -183,9 +190,11 @@ lib/nim/impure/rdstdin.nim
lib/nim/impure/re.nim
lib/nim/js/asyncjs.nim
lib/nim/js/dom.nim
+lib/nim/js/dom_extensions.nim
lib/nim/js/jsconsole.nim
lib/nim/js/jscore.nim
lib/nim/js/jsffi.nim
+lib/nim/js/jsre.nim
lib/nim/nimbase.h
lib/nim/nimhcr.nim
lib/nim/nimhcr.nim.cfg
@@ -202,6 +211,8 @@ lib/nim/posix/inotify.nim
lib/nim/posix/kqueue.nim
lib/nim/posix/linux.nim
lib/nim/posix/posix.nim
+lib/nim/posix/posix_freertos_consts.nim
+lib/nim/posix/posix_haiku.nim
lib/nim/posix/posix_linux_amd64.nim
lib/nim/posix/posix_linux_amd64_consts.nim
lib/nim/posix/posix_macos_amd64.nim
@@ -314,8 +325,10 @@ lib/nim/pure/selectors.nim
lib/nim/pure/smtp.nim
lib/nim/pure/smtp.nim.cfg
lib/nim/pure/ssl_certs.nim
+lib/nim/pure/ssl_config.nim
lib/nim/pure/stats.nim
lib/nim/pure/streams.nim
+lib/nim/pure/streamwrapper.nim
lib/nim/pure/strformat.nim
lib/nim/pure/strmisc.nim
lib/nim/pure/strscans.nim
@@ -337,8 +350,16 @@ lib/nim/pure/xmltree.nim
lib/nim/std/compilesettings.nim
lib/nim/std/decls.nim
lib/nim/std/editdistance.nim
+lib/nim/std/effecttraits.nim
+lib/nim/std/enumerate.nim
+lib/nim/std/exitprocs.nim
+lib/nim/std/isolation.nim
+lib/nim/std/jsonutils.nim
lib/nim/std/logic.nim
lib/nim/std/monotimes.nim
+lib/nim/std/private/globs.nim
+lib/nim/std/private/miscdollars.nim
+lib/nim/std/private/since.nim
lib/nim/std/private/underscored_calls.nim
lib/nim/std/sha1.nim
lib/nim/std/stackframes.nim
@@ -352,6 +373,7 @@ lib/nim/stdlib.nimble
lib/nim/system.nim
lib/nim/system/alloc.nim
lib/nim/system/ansi_c.nim
+lib/nim/system/arc.nim
lib/nim/system/arithm.nim
lib/nim/system/arithmetics.nim
lib/nim/system/assertions.nim
@@ -359,13 +381,15 @@ lib/nim/system/assign.nim
lib/nim/system/atomics.nim
lib/nim/system/avltree.nim
lib/nim/system/basic_types.nim
+lib/nim/system/bitmasks.nim
+lib/nim/system/cellseqs_v1.nim
+lib/nim/system/cellseqs_v2.nim
lib/nim/system/cellsets.nim
lib/nim/system/cgprocs.nim
lib/nim/system/channels.nim
lib/nim/system/chcks.nim
lib/nim/system/comparisons.nim
lib/nim/system/cyclebreaker.nim
-lib/nim/system/cyclicrefs_v2.nim
lib/nim/system/deepcopy.nim
lib/nim/system/dollars.nim
lib/nim/system/dyncalls.nim
@@ -398,16 +422,18 @@ lib/nim/system/mm/malloc.nim
lib/nim/system/mm/none.nim
lib/nim/system/mmdisp.nim
lib/nim/system/nimscript.nim
+lib/nim/system/orc.nim
lib/nim/system/osalloc.nim
lib/nim/system/platforms.nim
lib/nim/system/profiler.nim
-lib/nim/system/refs_v2.nim
lib/nim/system/repr.nim
lib/nim/system/repr_v2.nim
lib/nim/system/reprjs.nim
lib/nim/system/seqs_v2.nim
+lib/nim/system/seqs_v2_reimpl.nim
lib/nim/system/setops.nim
lib/nim/system/sets.nim
+lib/nim/system/stacktraces.nim
lib/nim/system/strmantle.nim
lib/nim/system/strs_v2.nim
lib/nim/system/syslocks.nim
@@ -476,6 +502,122 @@ lib/nim/wrappers/tinyc.nim
%%PORTDOCS%%%%DOCSDIR%%/html/channels.html
%%PORTDOCS%%%%DOCSDIR%%/html/codeowners.html
%%PORTDOCS%%%%DOCSDIR%%/html/colors.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/aliases.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/asciitables.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/ast.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/astalgo.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/bitsets.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/btrees.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/ccgmerge.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/ccgutils.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/cgen.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/cgendata.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/cgmeth.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/closureiters.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/cmdlinehelper.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/commands.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/condsyms.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/depends.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/dfa.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/docgen.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/docgen2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/dochack.js
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/enumtostr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/evaltempl.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/extccomp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/filter_tmpl.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/filters.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/gorgeimpl.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/guards.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/idents.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/idgen.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/importer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/incremental.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/injectdestructors.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/int128.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/isolation_check.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/jsgen.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/lambdalifting.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/lexer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/liftdestructors.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/liftlocals.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/lineinfos.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/linter.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/llstream.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/lookups.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/lowerings.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/macrocacheimpl.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/magicsys.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/main.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/modulegraphs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/modulepaths.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/modules.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/msgs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/ndi.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/nim.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/nimblecmd.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/nimconf.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/nimdoc.out.css
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/nimfix/prettybase.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/nimlexbase.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/nimpaths.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/nimsets.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/nodejs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/nversion.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/optimizer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/options.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/parampatterns.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/parser.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/passaux.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/passes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/pathutils.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/patterns.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/platform.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/plugins/active.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/plugins/itersgen.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/plugins/locals.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/pluginsupport.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/pragmas.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/prefixmatches.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/procfind.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/renderer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/renderverbatim.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/reorder.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/rod.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/rodutils.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/ropes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/saturate.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/scriptconfig.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/sem.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/semdata.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/semfold.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/semmacrosanity.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/semparallel.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/sempass2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/semtypinst.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/sighashes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/sigmatch.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/sourcemap.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/spawn.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/strutils2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/syntaxes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/theindex.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/transf.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/trees.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/treetab.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/typeallowed.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/types.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/typesrenderer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/varpartitions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/vm.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/vmconv.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/vmdef.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/vmdeps.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/vmgen.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/vmmarshal.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/vmprofiler.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compiler/wordrecg.html
%%PORTDOCS%%%%DOCSDIR%%/html/compilesettings.html
%%PORTDOCS%%%%DOCSDIR%%/html/complex.html
%%PORTDOCS%%%%DOCSDIR%%/html/contributing.html
@@ -498,18 +640,24 @@ lib/nim/wrappers/tinyc.nim
%%PORTDOCS%%%%DOCSDIR%%/html/docgen.html
%%PORTDOCS%%%%DOCSDIR%%/html/docgen_sample.html
%%PORTDOCS%%%%DOCSDIR%%/html/dochack.js
+%%PORTDOCS%%%%DOCSDIR%%/html/docstyle.html
%%PORTDOCS%%%%DOCSDIR%%/html/dollars.html
%%PORTDOCS%%%%DOCSDIR%%/html/dom.html
+%%PORTDOCS%%%%DOCSDIR%%/html/dom_extensions.html
%%PORTDOCS%%%%DOCSDIR%%/html/drnim.html
%%PORTDOCS%%%%DOCSDIR%%/html/dynlib.html
%%PORTDOCS%%%%DOCSDIR%%/html/editdistance.html
+%%PORTDOCS%%%%DOCSDIR%%/html/effecttraits.html
%%PORTDOCS%%%%DOCSDIR%%/html/encodings.html
%%PORTDOCS%%%%DOCSDIR%%/html/endians.html
+%%PORTDOCS%%%%DOCSDIR%%/html/enumerate.html
%%PORTDOCS%%%%DOCSDIR%%/html/epoll.html
%%PORTDOCS%%%%DOCSDIR%%/html/estp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/exitprocs.html
%%PORTDOCS%%%%DOCSDIR%%/html/fenv.html
%%PORTDOCS%%%%DOCSDIR%%/html/filters.html
%%PORTDOCS%%%%DOCSDIR%%/html/gc.html
+%%PORTDOCS%%%%DOCSDIR%%/html/globs.html
%%PORTDOCS%%%%DOCSDIR%%/html/hashes.html
%%PORTDOCS%%%%DOCSDIR%%/html/hcr.html
%%PORTDOCS%%%%DOCSDIR%%/html/heapqueue.html
@@ -520,16 +668,20 @@ lib/nim/wrappers/tinyc.nim
%%PORTDOCS%%%%DOCSDIR%%/html/httpclient.html
%%PORTDOCS%%%%DOCSDIR%%/html/httpcore.html
%%PORTDOCS%%%%DOCSDIR%%/html/idetools.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/inotify.html
%%PORTDOCS%%%%DOCSDIR%%/html/intern.html
%%PORTDOCS%%%%DOCSDIR%%/html/intsets.html
%%PORTDOCS%%%%DOCSDIR%%/html/io.html
+%%PORTDOCS%%%%DOCSDIR%%/html/isolation.html
%%PORTDOCS%%%%DOCSDIR%%/html/iterators.html
%%PORTDOCS%%%%DOCSDIR%%/html/iup.html
%%PORTDOCS%%%%DOCSDIR%%/html/jsconsole.html
%%PORTDOCS%%%%DOCSDIR%%/html/jscore.html
%%PORTDOCS%%%%DOCSDIR%%/html/jsffi.html
%%PORTDOCS%%%%DOCSDIR%%/html/json.html
+%%PORTDOCS%%%%DOCSDIR%%/html/jsonutils.html
+%%PORTDOCS%%%%DOCSDIR%%/html/jsre.html
%%PORTDOCS%%%%DOCSDIR%%/html/koch.html
%%PORTDOCS%%%%DOCSDIR%%/html/kqueue.html
%%PORTDOCS%%%%DOCSDIR%%/html/lenientops.html
@@ -551,6 +703,7 @@ lib/nim/wrappers/tinyc.nim
%%PORTDOCS%%%%DOCSDIR%%/html/memfiles.html
%%PORTDOCS%%%%DOCSDIR%%/html/mersenne.html
%%PORTDOCS%%%%DOCSDIR%%/html/mimetypes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/miscdollars.html
%%PORTDOCS%%%%DOCSDIR%%/html/monotimes.html
%%PORTDOCS%%%%DOCSDIR%%/html/mysql.html
%%PORTDOCS%%%%DOCSDIR%%/html/nativesockets.html
@@ -590,6 +743,7 @@ lib/nim/wrappers/tinyc.nim
%%PORTDOCS%%%%DOCSDIR%%/html/posix.html
%%PORTDOCS%%%%DOCSDIR%%/html/posix_utils.html
%%PORTDOCS%%%%DOCSDIR%%/html/postgres.html
+%%PORTDOCS%%%%DOCSDIR%%/html/prelude.html
%%PORTDOCS%%%%DOCSDIR%%/html/punycode.html
%%PORTDOCS%%%%DOCSDIR%%/html/random.html
%%PORTDOCS%%%%DOCSDIR%%/html/rationals.html
@@ -611,12 +765,15 @@ lib/nim/wrappers/tinyc.nim
%%PORTDOCS%%%%DOCSDIR%%/html/sha1.html
%%PORTDOCS%%%%DOCSDIR%%/html/sharedlist.html
%%PORTDOCS%%%%DOCSDIR%%/html/sharedtables.html
+%%PORTDOCS%%%%DOCSDIR%%/html/since.html
%%PORTDOCS%%%%DOCSDIR%%/html/smtp.html
%%PORTDOCS%%%%DOCSDIR%%/html/sqlite3.html
%%PORTDOCS%%%%DOCSDIR%%/html/ssl_certs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ssl_config.html
%%PORTDOCS%%%%DOCSDIR%%/html/stackframes.html
%%PORTDOCS%%%%DOCSDIR%%/html/stats.html
%%PORTDOCS%%%%DOCSDIR%%/html/streams.html
+%%PORTDOCS%%%%DOCSDIR%%/html/streamwrapper.html
%%PORTDOCS%%%%DOCSDIR%%/html/strformat.html
%%PORTDOCS%%%%DOCSDIR%%/html/strmisc.html
%%PORTDOCS%%%%DOCSDIR%%/html/strscans.html
@@ -629,6 +786,7 @@ lib/nim/wrappers/tinyc.nim
%%PORTDOCS%%%%DOCSDIR%%/html/tables.html
%%PORTDOCS%%%%DOCSDIR%%/html/terminal.html
%%PORTDOCS%%%%DOCSDIR%%/html/termios.html
+%%PORTDOCS%%%%DOCSDIR%%/html/testament.html
%%PORTDOCS%%%%DOCSDIR%%/html/theindex.html
%%PORTDOCS%%%%DOCSDIR%%/html/threadpool.html
%%PORTDOCS%%%%DOCSDIR%%/html/threads.html
@@ -677,11 +835,13 @@ lib/nim/wrappers/tinyc.nim
%%PORTDOCS%%%%DOCSDIR%%/overview.rst
%%PORTDOCS%%%%DOCSDIR%%/packaging.rst
%%PORTDOCS%%%%DOCSDIR%%/pegdocs.txt
+%%PORTDOCS%%%%DOCSDIR%%/prelude.rst
%%PORTDOCS%%%%DOCSDIR%%/readme.txt
%%PORTDOCS%%%%DOCSDIR%%/regexprs.txt
%%PORTDOCS%%%%DOCSDIR%%/sets_fragment.txt
%%PORTDOCS%%%%DOCSDIR%%/spawn.txt
%%PORTDOCS%%%%DOCSDIR%%/subexes.txt
+%%PORTDOCS%%%%DOCSDIR%%/testament.rst
%%PORTDOCS%%%%DOCSDIR%%/tools.rst
%%PORTDOCS%%%%DOCSDIR%%/tut1.rst
%%PORTDOCS%%%%DOCSDIR%%/tut2.rst