aboutsummaryrefslogtreecommitdiff
path: root/lang/nqc
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-09-02 10:50:52 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-09-02 10:50:52 +0000
commitba2185b16c05e5a0dc04082bef69ec752be8853f (patch)
treee84316a499f75cc041b7fa2f2ca75f893aa1b089 /lang/nqc
parent1d60dc45c24cfdbe3d2057007d3c1438b889c94e (diff)
downloadports-ba2185b16c05e5a0dc04082bef69ec752be8853f.tar.gz
ports-ba2185b16c05e5a0dc04082bef69ec752be8853f.zip
lang/nqc: Fix build with Clang 6
nqc/nqc.cpp:1088:41: error: no matching literal operator for call to 'operator""__DATE__' with arguments of types 'const char *' and 'unsigned int', and no matching literal operator template fprintf(STDERR,"nqc version %s (built "__DATE__", " __TIME__")\n", http://beefy11.nyi.freebsd.org/data/head-i386-default/p478276_s338342/logs/errors/nqc-3.1.r6.log
Notes
Notes: svn path=/head/; revision=478781
Diffstat (limited to 'lang/nqc')
-rw-r--r--lang/nqc/Makefile1
-rw-r--r--lang/nqc/files/patch-nqc_nqc.cpp18
2 files changed, 19 insertions, 0 deletions
diff --git a/lang/nqc/Makefile b/lang/nqc/Makefile
index ac57c91804d2..eccb1cbfd52a 100644
--- a/lang/nqc/Makefile
+++ b/lang/nqc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nqc
PORTVERSION= 3.1.r6
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://bricxcc.sourceforge.net/nqc/release/ \
ftp://ftp2.za.freebsd.org/pub/nqc/
diff --git a/lang/nqc/files/patch-nqc_nqc.cpp b/lang/nqc/files/patch-nqc_nqc.cpp
new file mode 100644
index 000000000000..3d04c1219d34
--- /dev/null
+++ b/lang/nqc/files/patch-nqc_nqc.cpp
@@ -0,0 +1,18 @@
+nqc/nqc.cpp:1088:41: error: no matching literal operator for call to 'operator""__DATE__' with arguments of types 'const char *' and 'unsigned int', and no matching literal operator template
+ fprintf(STDERR,"nqc version %s (built "__DATE__", " __TIME__")\n",
+
+Remove embedded build date and time completely as it would also
+prevent the build from being reproducible.
+
+--- nqc/nqc.cpp.orig 2018-09-02 10:44:16 UTC
++++ nqc/nqc.cpp
+@@ -1085,8 +1085,7 @@ void PrintError(RCX_Result error, const char *filename
+
+ void PrintVersion()
+ {
+- fprintf(STDERR,"nqc version %s (built "__DATE__", " __TIME__")\n",
+- VERSION_STRING);
++ fprintf(STDERR,"nqc version %s\n", VERSION_STRING);
+ fprintf(STDERR," Copyright (C) 2005 John Hansen. All Rights Reserved.\n");
+ }
+