aboutsummaryrefslogtreecommitdiff
path: root/lang/ocaml-autoconf
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-03-24 11:28:57 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-03-24 11:28:57 +0000
commit37b75a0fb357ae87d9fbcce67cbdcb91ff1975ce (patch)
treeb363fd3695e664181d72f1b915dc4ef821d3d3d1 /lang/ocaml-autoconf
parent0226da9003047ea1cbaa8f0b221a3419bf222410 (diff)
downloadports-37b75a0fb357ae87d9fbcce67cbdcb91ff1975ce.tar.gz
ports-37b75a0fb357ae87d9fbcce67cbdcb91ff1975ce.zip
- Add lang/ocaml-autoconf, ocaml macros module for autoconf.
Notes
Notes: svn path=/head/; revision=251436
Diffstat (limited to 'lang/ocaml-autoconf')
-rw-r--r--lang/ocaml-autoconf/Makefile36
-rw-r--r--lang/ocaml-autoconf/distinfo3
-rw-r--r--lang/ocaml-autoconf/pkg-descr4
3 files changed, 43 insertions, 0 deletions
diff --git a/lang/ocaml-autoconf/Makefile b/lang/ocaml-autoconf/Makefile
new file mode 100644
index 000000000000..435677e7b768
--- /dev/null
+++ b/lang/ocaml-autoconf/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ocaml.m4
+# Date created: 24 Marth 2010
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= autoconf
+PORTVERSION= 1.0
+CATEGORIES= lang
+MASTER_SITES= http://forge.ocamlcore.org/frs/download.php/181/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Autoconf module for ocaml
+
+NO_BUILD= yes
+
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+AC_SUBDIR= ${PREFIX}/share/aclocal
+PLIST_FILES= share/aclocal/ocaml.m4
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ocaml.m4.txt
+.endif
+
+do-install:
+ ${MKDIR} ${AC_SUBDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/ocaml.m4 ${AC_SUBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/ocaml.m4.txt ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/ocaml-autoconf/distinfo b/lang/ocaml-autoconf/distinfo
new file mode 100644
index 000000000000..bb72810e4a36
--- /dev/null
+++ b/lang/ocaml-autoconf/distinfo
@@ -0,0 +1,3 @@
+MD5 (ocaml-autoconf-1.0.tar.gz) = 2eab5efad4364d2f0114f38e00af09ac
+SHA256 (ocaml-autoconf-1.0.tar.gz) = 67e85520f65c033c86e99e5438e51657e777579034570527c1b2c62096ecb004
+SIZE (ocaml-autoconf-1.0.tar.gz) = 11337
diff --git a/lang/ocaml-autoconf/pkg-descr b/lang/ocaml-autoconf/pkg-descr
new file mode 100644
index 000000000000..5a9e4acef883
--- /dev/null
+++ b/lang/ocaml-autoconf/pkg-descr
@@ -0,0 +1,4 @@
+This port contains standard, useful autoconf macros for detecting
+OCaml, findlib, OCaml packages, etc.
+
+WWW: http://forge.ocamlcore.org/projects/ocaml-autoconf/