aboutsummaryrefslogtreecommitdiff
path: root/lang/opendylan/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-12-17 18:24:15 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-12-17 18:24:15 +0000
commitf4139461445456448113bb6493b673b01b21f450 (patch)
tree35b62a109ff669e904a1680c34a8c334862f6486 /lang/opendylan/Makefile
parented021df9c9ba98f79aa9e853ea56b22cf7af4c3f (diff)
downloadports-f4139461445456448113bb6493b673b01b21f450.tar.gz
ports-f4139461445456448113bb6493b673b01b21f450.zip
Open Dylan compiles to native code and has a full-featured IDE including an
incremental development mode, browsing of runtime objects, remote debugging, etc. Open Dylan currently only runs on the x86 platform and the IDE does not yet run on the Linux version. Open Dylan is in many ways a mature implementation. If you are new to the language, choose Open Dylan if you can. WWW: http://www.opendylan.org/
Notes
Notes: svn path=/head/; revision=203941
Diffstat (limited to 'lang/opendylan/Makefile')
-rw-r--r--lang/opendylan/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/lang/opendylan/Makefile b/lang/opendylan/Makefile
new file mode 100644
index 000000000000..30c7d0d85d18
--- /dev/null
+++ b/lang/opendylan/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: opendylan
+# Date created: 2007-12-15
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= opendylan
+DISTVERSION= 1.0beta4
+CATEGORIES= lang
+MASTER_SITES= http://www.opendylan.org/downloads/opendylan/${DISTVERSION}/
+DISTNAME= ${PORTNAME}-${DISTVERSION}-x86-FreeBSD6
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Open Dylan project native command-line compiler for Dylan
+
+IA32_BINARY_PORT= yes
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+DATADIR= ${PREFIX}/lib/${PORTNAME}
+
+WRAPPERS= opendylan make-dylan-app
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700000
+LIB_DEPENDS+= c.6:${PORTSDIR}/misc/compat6x
+.endif
+
+do-build:
+.for f in ${WRAPPERS}
+ @(${ECHO_CMD} "#!${SH}"; \
+ ${ECHO_CMD} 'export LD_LIBRARY_PATH="${DATADIR}/lib"'; \
+ ${ECHO_CMD} 'exec ${DATADIR}/bin/${f} "$$@"') > ${WRKSRC}/${f}
+.endfor
+
+do-install:
+ ${MKDIR} ${DATADIR}
+.for d in bin databases lib sources
+ ${CP} -r ${WRKSRC}/${d} ${DATADIR}
+.endfor
+.for f in ${WRAPPERS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.post.mk>