aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.16
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-11-11 05:37:39 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-11-11 05:37:39 +0000
commitdbc8aa6cc1cb1abadce30cfe133c7a5c2ed2f34b (patch)
treedeebef625a152490a0bbcb7e5602d05a59b1c010 /lang/perl5.16
parentc2e32ac36f406a78d4fb097baacb7fd65c4817d8 (diff)
downloadports-dbc8aa6cc1cb1abadce30cfe133c7a5c2ed2f34b.tar.gz
ports-dbc8aa6cc1cb1abadce30cfe133c7a5c2ed2f34b.zip
Use bsd.port.{pre,post}.mk. Either use them to avoid having to define
something already there (PORTOBJFORMAT, OSVERSION) or move stuff from after .include <bsd.port.mk> to before. (This is not by any means the complete list but just the ones I've noticed recently.)
Notes
Notes: svn path=/head/; revision=14465
Diffstat (limited to 'lang/perl5.16')
-rw-r--r--lang/perl5.16/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/lang/perl5.16/Makefile b/lang/perl5.16/Makefile
index ff11ae222c62..8ecf159155dc 100644
--- a/lang/perl5.16/Makefile
+++ b/lang/perl5.16/Makefile
@@ -3,7 +3,7 @@
# Date created: 16 April 1995
# Whom: markm
#
-# $Id: Makefile,v 1.25 1998/08/15 16:33:13 markm Exp $
+# $Id: Makefile,v 1.26 1998/10/12 06:51:07 markm Exp $
#
DISTNAME= perl5.005_02
@@ -18,8 +18,9 @@ HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= -sde -Dprefix=${PREFIX}
-OSVER!= sysctl -n kern.osreldate
-.if ${OSVER} > 300003
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 300003
BROKEN= perl is in system
.endif
@@ -87,4 +88,4 @@ post-install:
@ln -sf ${PREFIX}/bin/perl ${PREFIX}/bin/perl5
@(cd /usr/include && ${PREFIX}/bin/h2ph *.h machine/*.h sys/*.h)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>