aboutsummaryrefslogtreecommitdiff
path: root/lang/php4/Makefile
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2003-11-05 11:06:59 +0000
committerJames E. Housley <jeh@FreeBSD.org>2003-11-05 11:06:59 +0000
commit7c34833e473f9b66b912a04dee95c6ec98357167 (patch)
tree693aad04ec2643f03f0ecff00f9c4c06eb576341 /lang/php4/Makefile
parent14988eebf4bf7cc15cf2823acfe60dc5b66b789e (diff)
downloadports-7c34833e473f9b66b912a04dee95c6ec98357167.tar.gz
ports-7c34833e473f9b66b912a04dee95c6ec98357167.zip
Update to 4.3.4 final release.
PR: 58914 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=93128
Diffstat (limited to 'lang/php4/Makefile')
-rw-r--r--lang/php4/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 8ba3dbe30cf9..7223038f6c80 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -20,7 +20,7 @@
#
PORTNAME= php4
-PORTVERSION= 4.3.4.r1
+PORTVERSION= 4.3.4
PORTREVISION= 0
CATEGORIES?= lang devel www
MASTER_SITES= http://www.php.net/distributions/:release \
@@ -45,7 +45,7 @@ PKGNAMESUFFIX= -cli
.endif
.endif
DISTNAME= php-${PORTVERSION:S/.r/RC/}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:rc
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:release
MAINTAINER?= sysadmin@alexdupre.com
COMMENT= PHP Scripting Language (Apache Module and CLI)
@@ -143,13 +143,6 @@ BATCH= yes
IS_INTERACTIVE= yes
.endif
-.if !defined(WITHOUT_APACHE)
-APXS?= ${LOCALBASE}/sbin/apxs
-PLIST_SUB+= APACHE=""
-.else
-PLIST_SUB+= APACHE="@comment "
-.endif
-
WRKDIR?= ${WRKDIRPREFIX}${.CURDIR}/work
PHP4_OPTFILE?= ${HOME}/php4_options
@@ -342,7 +335,7 @@ CONFIGURE_ARGS+=--with-interbase=${LOCALBASE}/firebird
.endif
.if defined(WITH_MBSTRING)
-CONFIGURE_ARGS+=--enable-mbstring --enable-mbregex
+CONFIGURE_ARGS+=--enable-mbstring
.endif
.if defined(WITH_MCAL)
@@ -529,6 +522,7 @@ CONFIGURE_ARGS+=--with-zlib=yes
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_APACHE)
+APXS?= ${LOCALBASE}/sbin/apxs
.if exists(${LOCALBASE}/include/apache2/apr.h)
WITH_APACHE2= yes
.endif