aboutsummaryrefslogtreecommitdiff
path: root/lang/php53
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-06-14 20:38:26 +0000
committerAlex Dupre <ale@FreeBSD.org>2005-06-14 20:38:26 +0000
commit4107b871cac107a1e42b4411664be22e8a2ea6da (patch)
tree4dd818d445b7a6de71bdc2379ada5eec533e2c10 /lang/php53
parente2cce2e62c890fbb09c73c1fb12d86da219dfa75 (diff)
downloadports-4107b871cac107a1e42b4411664be22e8a2ea6da.tar.gz
ports-4107b871cac107a1e42b4411664be22e8a2ea6da.zip
Add support for zend multibyte.
PR: ports/76527 Submitted by: Shinsuke Matsui <poppen@karashi.org> Strongly desired by: Lapo Luchini <lapo@lapo.it>
Notes
Notes: svn path=/head/; revision=137461
Diffstat (limited to 'lang/php53')
-rw-r--r--lang/php53/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index aa3dfad1e6c2..992cb18ca979 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -76,6 +76,7 @@ OPTIONS= REDIRECT "Enable force-cgi-redirect support" off \
OPTIONS= APACHE2 "Use apache 2.x instead of apache 1.3.x" off
.endif
OPTIONS+= DEBUG "Enable debug" off \
+ MULTIBYTE "Enable zend multibyte support" off \
IPV6 "Enable ipv6 support" on
EXT_DIR= 20041030
@@ -141,6 +142,10 @@ CONFIGURE_ARGS+=--enable-debug
EXT_DIR:= ${EXT_DIR}-debug
.endif
+.if defined(WITH_MULTIBYTE)
+CONFIGURE_ARGS+=--enable-zend-multibyte
+.endif
+
PLIST_SUB+= SAPI_FILE=${SAPI_FILE}
.if ${OSVERSION} < 400014 || defined(WITHOUT_IPV6)