aboutsummaryrefslogtreecommitdiff
path: root/lang/php55
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 16:24:00 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 16:24:00 +0000
commitf4f46a920e21b409b3f3b16873c6cef1eb4af378 (patch)
tree111c3e996440f35b3a05e66700954340c9919761 /lang/php55
parent4007e179a6cb2c28428cd709099b5c1ff6b65402 (diff)
downloadports-f4f46a920e21b409b3f3b16873c6cef1eb4af378.tar.gz
ports-f4f46a920e21b409b3f3b16873c6cef1eb4af378.zip
Fix unixODBC vs libiodbc conflicts
Always rely on unixODBC each time a port is looking for libodbc.so Remove odbc compat from libiodbc This allows to install both kde and gnome at the same time While here: - Convert libiodbc to USES=libtool - Convert a bunch of libiodbc dependencies to USES=libtool - Chase libiodbc.so shlib change - Stagify some ports - Convert some ports to USES=pgsql Discussed with: rakuco (kde) With hat: portmgr
Notes
Notes: svn path=/head/; revision=353029
Diffstat (limited to 'lang/php55')
-rw-r--r--lang/php55/Makefile.ext22
1 files changed, 0 insertions, 22 deletions
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index b20f53928454..1e48b4247523 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -207,10 +207,6 @@ MYSQLND_DESC= Use MySQL Native Driver
.if ${PHP_MODNAME} == "odbc"
CONFIGURE_ARGS+=--enable-odbc
-
-OPTIONS_DEFINE= IODBC
-
-IODBC_DESC= Use the iODBC driver instead of unixODBC
.endif
.if ${PHP_MODNAME} == "openssl"
@@ -263,10 +259,6 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
-OPTIONS_DEFINE= IODBC
-
-IODBC_DESC= Use the iODBC driver instead of unixODBC
-
USE_PHP= pdo
USE_PHP_BUILD= yes
.endif
@@ -561,15 +553,8 @@ post-extract:
.endif
.if ${PHP_MODNAME} == "odbc"
-. if ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= libiodbc.so:${PORTSDIR}/databases/libiodbc
-
-CONFIGURE_ARGS+=--with-iodbc=${LOCALBASE}
-. else
LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
-
CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
-. endif
.endif
.if ${PHP_MODNAME} == "pdo_dblib"
@@ -581,15 +566,8 @@ LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
-. if ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= libiodbc.so:${PORTSDIR}/databases/libiodbc
-
-CONFIGURE_ARGS+=--with-pdo-odbc=iODBC,${LOCALBASE}
-. else
LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
-
CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
-. endif
.endif
.if ${PHP_MODNAME} == "pdo_mysql"