aboutsummaryrefslogtreecommitdiff
path: root/lang/php56
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2016-07-20 20:04:50 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2016-07-20 20:04:50 +0000
commitbb82b9262630c93244656da3a07c30559b8dc3ff (patch)
treed7387b709105b93979bf7f1560c9c431e5e966e7 /lang/php56
parent242e6f8584641aeeec366cbcdfe1818b4839497a (diff)
downloadports-bb82b9262630c93244656da3a07c30559b8dc3ff.tar.gz
ports-bb82b9262630c93244656da3a07c30559b8dc3ff.zip
If DEFAULT_VERSIONS=php=* is set, then PHP_DEFAULT will be overridden
in bsd.default-versions.mk later, and the value from the Makefile will not be used at all. We would change bsd.default-versions.mk, but really these ports should not be changing what the "default" it. Change to modifying what the "current" version is as PHP_VER. This fixes some cases of 'make check-sanity' not passing for php extension ports in Poudriere where there is no LOCALBASE/etc/php.conf to set a proper PHP_VER. In these cases the PHP_DEFAULT value (of 5.6) is used rather than the version set by the extension Makefile and the later checks for whether that version has that extension may incorrectly error.
Notes
Notes: svn path=/head/; revision=418853
Diffstat (limited to 'lang/php56')
-rw-r--r--lang/php56/Makefile2
-rw-r--r--lang/php56/Makefile.ext2
2 files changed, 2 insertions, 2 deletions
diff --git a/lang/php56/Makefile b/lang/php56/Makefile
index 93c93c93fde8..c0d2c7712031 100644
--- a/lang/php56/Makefile
+++ b/lang/php56/Makefile
@@ -89,7 +89,7 @@ CONFIGURE_ARGS+=--enable-fpm \
.if defined(PKGNAMEPREFIX)
USES+= php
-PHP_DEFAULT= 5.6
+PHP_VER= 56
IGNORE_WITH_PHP=53 54 5
USE_APACHE= 22+
.include "${PORTSDIR}/Mk/bsd.apache.mk"
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index 609fcbf7bf29..9a7942269e45 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -2,7 +2,7 @@ COMMENT= The ${PHP_MODNAME} shared extension for php
USES+= php:ext
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
-PHP_DEFAULT= 5.6
+PHP_VER= 56
IGNORE_WITH_PHP= 55 70
EXTSUBDIR= ${DISTNAME}/ext/${PHP_MODNAME}