aboutsummaryrefslogtreecommitdiff
path: root/lang/php71
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-03-17 21:42:48 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-03-17 21:42:48 +0000
commit42fcb4986989cd5f677b75bd126e98a2371820cc (patch)
tree76c0bc29afdac344a3aac11507a4ecd4fe68b442 /lang/php71
parent6a70ebab687bd4d06b582f1747e0f2b03f42e04a (diff)
downloadports-42fcb4986989cd5f677b75bd126e98a2371820cc.tar.gz
ports-42fcb4986989cd5f677b75bd126e98a2371820cc.zip
Turn off DTRACE option by default for mips. It fails the exact same way
that armvX do. While here, remove duplicate OPTIONS_EXCLUDE_aarch64 line, and sort. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=464849
Diffstat (limited to 'lang/php71')
-rw-r--r--lang/php71/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/lang/php71/Makefile b/lang/php71/Makefile
index 507870dc5272..8b67ca7e60aa 100644
--- a/lang/php71/Makefile
+++ b/lang/php71/Makefile
@@ -34,20 +34,17 @@ USE_GNOME= libxml2
OPTIONS_DEFINE+=CLI CGI FPM EMBED PHPDBG DEBUG DTRACE IPV6 MAILHEAD LINKTHR ZTS
OPTIONS_DEFAULT=CLI CGI FPM EMBED LINKTHR DTRACE
+OPTIONS_EXCLUDE_DragonFly= DTRACE
# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
OPTIONS_EXCLUDE_aarch64= DTRACE
# dt_modtext:opensolaris/ib/libdtrace/common/dt_link.c: arm not impemented
OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE
# Bug 197128: No ASM code for MIPS/MIPS64, disable FPM
-OPTIONS_EXCLUDE_mips= FPM
-OPTIONS_EXCLUDE_mips64= FPM
-OPTIONS_SUB= yes
-
-OPTIONS_EXCLUDE_DragonFly= DTRACE
-# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
-OPTIONS_EXCLUDE_aarch64= DTRACE
+OPTIONS_EXCLUDE_mips= DTRACE FPM
+OPTIONS_EXCLUDE_mips64= DTRACE FPM
OPTIONS_EXCLUDE_sparc64= DTRACE
+OPTIONS_SUB= yes
CLI_DESC= Build CLI version
CGI_DESC= Build CGI version