aboutsummaryrefslogtreecommitdiff
path: root/lang/php71
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2017-12-17 10:19:10 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2017-12-17 10:19:10 +0000
commit86d4a95570de4702cf4d6e50d2cac277456f08b9 (patch)
tree02204a2ada702960d135f28f397ab35fc8675f2c /lang/php71
parent7d7e2a54d798920ce51048bcae66142df3c0d24d (diff)
downloadports-86d4a95570de4702cf4d6e50d2cac277456f08b9.tar.gz
ports-86d4a95570de4702cf4d6e50d2cac277456f08b9.zip
Add an upstream patch:
http://git.php.net/?p=php-src.git;a=commit;h=72ec23d8233ac9a2071f991752cff55febb167d5 This eliminate a warning while building with clang on 32-bit system and enable other programs' configure scripts test PHP feature with `-Werror` Approved by: tz (maintainer)
Notes
Notes: svn path=/head/; revision=456526
Diffstat (limited to 'lang/php71')
-rw-r--r--lang/php71/Makefile2
-rw-r--r--lang/php71/files/patch-Zend_zend__hash.c11
-rw-r--r--lang/php71/files/patch-Zend_zend__hash.h11
3 files changed, 23 insertions, 1 deletions
diff --git a/lang/php71/Makefile b/lang/php71/Makefile
index 9ab219ca7147..ee26bcb54442 100644
--- a/lang/php71/Makefile
+++ b/lang/php71/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php71
PORTVERSION= 7.1.12
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${PORTVERSION}
diff --git a/lang/php71/files/patch-Zend_zend__hash.c b/lang/php71/files/patch-Zend_zend__hash.c
new file mode 100644
index 000000000000..fd92c31802ae
--- /dev/null
+++ b/lang/php71/files/patch-Zend_zend__hash.c
@@ -0,0 +1,11 @@
+--- Zend/zend_hash.c.orig 2017-12-13 20:22:03 UTC
++++ Zend/zend_hash.c
+@@ -1544,7 +1544,7 @@ ZEND_API void ZEND_FASTCALL zend_hash_ap
+ }
+
+
+-ZEND_API void ZEND_FASTCALL zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int num_args, ...)
++ZEND_API void zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int num_args, ...)
+ {
+ uint32_t idx;
+ Bucket *p;
diff --git a/lang/php71/files/patch-Zend_zend__hash.h b/lang/php71/files/patch-Zend_zend__hash.h
new file mode 100644
index 000000000000..ba3f8fd157fd
--- /dev/null
+++ b/lang/php71/files/patch-Zend_zend__hash.h
@@ -0,0 +1,11 @@
+--- Zend/zend_hash.h.orig 2017-12-13 20:15:42 UTC
++++ Zend/zend_hash.h
+@@ -138,7 +138,7 @@ ZEND_API void ZEND_FASTCALL zend_hash_gr
+ ZEND_API void ZEND_FASTCALL zend_hash_graceful_reverse_destroy(HashTable *ht);
+ ZEND_API void ZEND_FASTCALL zend_hash_apply(HashTable *ht, apply_func_t apply_func);
+ ZEND_API void ZEND_FASTCALL zend_hash_apply_with_argument(HashTable *ht, apply_func_arg_t apply_func, void *);
+-ZEND_API void ZEND_FASTCALL zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int, ...);
++ZEND_API void zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int, ...);
+
+ /* This function should be used with special care (in other words,
+ * it should usually not be used). When used with the ZEND_HASH_APPLY_STOP