aboutsummaryrefslogtreecommitdiff
path: root/lang/php73/files
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2019-01-08 15:54:23 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2019-01-08 15:54:23 +0000
commitdfd2e3f597fed08d52ba0a2049813646ce09c8bd (patch)
treec430603106987ddbe8219748cd8e55c5de02a46a /lang/php73/files
parent477f2358a0693b63b76bf42ce973e53c284984d0 (diff)
downloadports-dfd2e3f597fed08d52ba0a2049813646ce09c8bd.tar.gz
ports-dfd2e3f597fed08d52ba0a2049813646ce09c8bd.zip
lang/php73: Fix "Bus error (core dumped)" by disabling ifuncs
PHP 7.3 uses ifuncs optimisations which generates a list of problems on FreeBSD: https://bugs.php.net/bug.php?id=77284 https://bugs.php.net/bug.php?id=77279 https://bugs.php.net/bug.php?id=77261 Therefore ifuncs will be disabled in PHP 7.3.1. To make it usable until the release, we import the patch until then: https://github.com/php/php-src/commit/291589114aa9be899cf7d5d874c3b5bbdb35f336 PR: 233024 Submitted by: Pascal Christen <pascal.christen@hostpoint.ch> MFH: 2019Q1
Notes
Notes: svn path=/head/; revision=489721
Diffstat (limited to 'lang/php73/files')
-rw-r--r--lang/php73/files/patch-acinclude.m48
-rw-r--r--lang/php73/files/patch-configure.ac14
2 files changed, 18 insertions, 4 deletions
diff --git a/lang/php73/files/patch-acinclude.m4 b/lang/php73/files/patch-acinclude.m4
index ffa61dd99264..531c9ab426fd 100644
--- a/lang/php73/files/patch-acinclude.m4
+++ b/lang/php73/files/patch-acinclude.m4
@@ -1,4 +1,4 @@
---- acinclude.m4.orig 2018-08-14 11:39:24 UTC
+--- acinclude.m4.orig 2018-12-04 16:12:30 UTC
+++ acinclude.m4
@@ -971,15 +971,9 @@ dnl ------------------------------------
if test "$3" != "shared" && test "$3" != "yes" && test "$4" = "cli"; then
@@ -32,7 +32,7 @@
dnl Some systems require that we link $2 to $1 when building
])
-@@ -2934,8 +2922,7 @@ dnl in GNU Make which causes the .d file
+@@ -2970,8 +2958,7 @@ dnl in GNU Make which causes the .d file
$abs_srcdir/$ac_provsrc:;
$ac_bdir[$]ac_hdrobj: $abs_srcdir/$ac_provsrc
@@ -42,7 +42,7 @@
\$(PHP_DTRACE_OBJS): $ac_bdir[$]ac_hdrobj
EOF
-@@ -2954,12 +2941,12 @@ dnl Always attempt to create both PIC an
+@@ -2990,12 +2977,12 @@ dnl Always attempt to create both PIC an
$ac_bdir[$]ac_provsrc.lo: \$(PHP_DTRACE_OBJS)
echo "[#] Generated by Makefile for libtool" > \$[]@
@test -d "$dtrace_lib_dir" || mkdir $dtrace_lib_dir
@@ -57,7 +57,7 @@
echo "non_pic_object=[']$dtrace_prov_name[']" >> \$[]@ [;\\]
else [\\]
echo "non_pic_object='none'" >> \$[]@ [;\\]
-@@ -2971,7 +2958,7 @@ EOF
+@@ -3007,7 +2994,7 @@ EOF
*)
cat>>Makefile.objects<<EOF
$ac_bdir[$]ac_provsrc.o: \$(PHP_DTRACE_OBJS)
diff --git a/lang/php73/files/patch-configure.ac b/lang/php73/files/patch-configure.ac
new file mode 100644
index 000000000000..4305bd53e717
--- /dev/null
+++ b/lang/php73/files/patch-configure.ac
@@ -0,0 +1,14 @@
+--- configure.ac.orig 2019-01-08 12:14:44 UTC
++++ configure.ac
+@@ -579,7 +579,10 @@ PHP_SOCKADDR_CHECKS
+
+ dnl Checks for GCC function attributes on all systems except ones without glibc
+ dnl Fix for these systems is already included in GCC 7, but not on GCC 6
+-AS_CASE([$host_alias], [*-*-*android*|*-*-*uclibc*|*-*-*musl*], [true], [
++dnl
++dnl At least some versions of FreeBSD seem to have buggy ifunc support, see
++dnl bug #77284. Conservatively don't use ifuncs on FreeBSD.
++AS_CASE([$host_alias], [*-*-*android*|*-*-*uclibc*|*-*-*musl*|*freebsd*], [true], [
+ AX_GCC_FUNC_ATTRIBUTE([ifunc])
+ AX_GCC_FUNC_ATTRIBUTE([target])
+ ])