aboutsummaryrefslogtreecommitdiff
path: root/lang/php74
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-02-06 18:46:36 +0000
committerStefan Eßer <se@FreeBSD.org>2022-02-06 18:46:36 +0000
commitd4b3ad64a4ca97d38fdce4ff6821758b5c2a9dcb (patch)
treecf5b021d97ee42e7b39588699ccc5ba5d0ec71c6 /lang/php74
parentbdd2d4af9630fdc1157d49bd193e8195c3240e9e (diff)
downloadports-d4b3ad64a4ca97d38fdce4ff6821758b5c2a9dcb.tar.gz
ports-d4b3ad64a4ca97d38fdce4ff6821758b5c2a9dcb.zip
lang/php??: make CONFLICTS_INSTALL visible to PHP module ports
The definition of CONFLICTS_INSTALL already included ${PKGNAMESUFFIX}, but in a block that was conditional on ${PKGNAMESUFFIX} not being defined, defying the purpose. After this change all ports that refer to the lang/php?? interpreter ports get an automatic CONFLICTS_INSTALL definition that prevents the installation of the same module for multiple interpreter versions. This change adds correct CONFLICTS_INSTALL definitions to hundreds of PHP ports that previously lacked any such definition. PHP modules can override this generated CONFLICTS_INSTALL definition in their Makefiles, if required. Approved by: portmgr (implicit)
Diffstat (limited to 'lang/php74')
-rw-r--r--lang/php74/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/php74/Makefile b/lang/php74/Makefile
index e5984688cca2..844391f2b287 100644
--- a/lang/php74/Makefile
+++ b/lang/php74/Makefile
@@ -18,6 +18,8 @@ USES+= compiler:c11 tar:xz cpe gnome pkgconfig
CPE_PRODUCT= php
NO_OPTIONS_SORT=yes
+CONFLICTS_INSTALL?= php[0-9][0-9]${PKGNAMESUFFIX}
+
.if !defined(PKGNAMESUFFIX)
LIB_DEPENDS= libpcre2-8.so:devel/pcre2 \
libargon2.so:security/libargon2
@@ -36,8 +38,6 @@ USE_GNOME= libxml2
# PR230207 Allow relocations against read-only segments (override lld default)
LDFLAGS_i386= -Wl,-z,notext
-CONFLICTS_INSTALL= php[0-9][0-9]${PKGNAMESUFFIX}
-
OPTIONS_DEFINE+=CLI CGI FPM EMBED PHPDBG DEBUG DTRACE IPV6 MYSQLND LINKTHR ZTS
OPTIONS_DEFAULT=CLI CGI FPM EMBED MYSQLND LINKTHR DTRACE
OPTIONS_EXCLUDE_DragonFly= DTRACE