aboutsummaryrefslogtreecommitdiff
path: root/lang/php83
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-11-22 23:52:22 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-11-23 22:02:57 +0000
commit8667a82724a9c7d2560c438d98f23990d08a08eb (patch)
tree4bf0b7dd1249ffddcb177f832b4d5a383127afdd /lang/php83
parentc62bdd591140f038cdc47fe238483fd91ee067f8 (diff)
downloadports-8667a82724a9c7d2560c438d98f23990d08a08eb.tar.gz
ports-8667a82724a9c7d2560c438d98f23990d08a08eb.zip
lang/php83: Update version 8.3.0RC6=>8.3.0
- Switch to system pcre - Switch to libenchant-2 for enchant extension - Switch to panda-cclient for imap extension and remove cclient OPTION as this has been marked DEPRECATED - Remove option for mysqli as mysqli no longer supports external mysql - Switch to libedit for readline extension Changelog: https://www.php.net/ChangeLog-8.php#8.3.0
Diffstat (limited to 'lang/php83')
-rw-r--r--lang/php83/Makefile73
-rw-r--r--lang/php83/distinfo6
-rw-r--r--lang/php83/files/patch-ext_mysqli_mysqli__api.c12
-rw-r--r--lang/php83/files/patch-ext_mysqli_mysqli__nonapi.c12
-rw-r--r--lang/php83/files/patch-ext_mysqli_mysqli__prop.c12
-rw-r--r--lang/php83/pkg-plist7
6 files changed, 34 insertions, 88 deletions
diff --git a/lang/php83/Makefile b/lang/php83/Makefile
index d3f8f7f65a0b..060b7c772f72 100644
--- a/lang/php83/Makefile
+++ b/lang/php83/Makefile
@@ -1,8 +1,7 @@
PORTNAME= php83
-DISTVERSION= 8.3.0RC6
+DISTVERSION= 8.3.0
CATEGORIES?= lang devel www
-MASTER_SITES= https://downloads.php.net/~jakub/ \
- https://downloads.php.net/~eric/
+MASTER_SITES= PHP/distributions
DISTNAME= php-${DISTVERSION}
MAINTAINER= bofh@FreeBSD.org
@@ -11,36 +10,38 @@ WWW= https://www.php.net/
LICENSE= PHP301
-USES+= compiler:c11 cpe gnome pkgconfig tar:xz
+USES+= compiler:c11 cpe gnome localbase pkgconfig tar:xz
CPE_PRODUCT= php
PHP_VER= 83
CONFLICTS_INSTALL?= php[0-9][0-9]${PKGNAMESUFFIX}
.if !defined(PKGNAMESUFFIX)
+BUILD_DEPENDS= re2c>0:devel/re2c
LIB_DEPENDS= libargon2.so:security/libargon2 \
libpcre2-8.so:devel/pcre2
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --disable-all \
- --program-prefix="" \
- --with-config-file-scan-dir=${PREFIX}/etc/php \
- --with-layout=GNU \
- --with-libxml \
- --with-openssl \
- --with-password-argon2=${LOCALBASE}
-DESTDIRNAME= INSTALL_ROOT
-
-USES+= autoreconf:build localbase ssl
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= \
+ --disable-all \
+ --program-prefix="" \
+ --with-config-file-scan-dir=${PREFIX}/etc/php \
+ --with-layout=GNU \
+ --with-libxml \
+ --with-openssl \
+ --with-password-argon2=${LOCALBASE} \
+ --with-external-pcre=${LOCALBASE}
+
+USES+= autoreconf:build ssl
USE_GNOME= libxml2
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
# PR230207 Allow relocations against read-only segments (override lld default)
LDFLAGS_i386= -Wl,-z,notext
-OPTIONS_DEFINE+= CGI CLI DEBUG DTRACE EMBED FPM IPV6 LINKTHR \
+OPTIONS_DEFINE+=CGI CLI DEBUG DTRACE EMBED FPM IPV6 LINKTHR \
MYSQLND NOASLR PHPDBG ZTS
-OPTIONS_DEFAULT= CGI CLI DTRACE EMBED FPM LINKTHR MYSQLND
+OPTIONS_DEFAULT= CGI CLI DTRACE EMBED FPM LINKTHR MYSQLND
OPTIONS_EXCLUDE_DragonFly= DTRACE
# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
OPTIONS_EXCLUDE_aarch64= DTRACE
@@ -88,6 +89,8 @@ PHPDBG_VARS= PHP_SAPI+=phpdbg
ZTS_CONFIGURE_ON= --enable-zts
ZTS_CONFIGURE_ENV= pthreads_working="yes"
+DESTDIRNAME= INSTALL_ROOT
+
.if defined(PKGNAMEPREFIX)
USES+= apache
PLIST= ${PKGDIR}/pkg-plist.mod
@@ -267,9 +270,9 @@ USE_GNOME= libxml2
.endif
.if ${PHP_MODNAME} == "enchant"
-LIB_DEPENDS+= libenchant.so:textproc/enchant
-CONFIGURE_ARGS+= --with-enchant=${LOCALBASE}
-USES+= pkgconfig
+LIB_DEPENDS+= libenchant-2.so:textproc/enchant2
+CONFIGURE_ARGS+=--with-enchant=${LOCALBASE}
+USES+= pkgconfig
.endif
.if ${PHP_MODNAME} == "exif"
@@ -347,13 +350,7 @@ USES+= iconv:translit
.if ${PHP_MODNAME} == "imap"
PHP_MOD_PRIO= 30
-OPTIONS_RADIO= CLIENT
-OPTIONS_RADIO_CLIENT= CCLIENT PANDA
-OPTIONS_DEFAULT= PANDA
-CCLIENT_DESC= Uses the original but unmaintained cclient
-PANDA_DESC= Uses the forked panda-cclient instead of the original cclient
-PANDA_LIB_DEPENDS= libc-client.so.2010:mail/panda-cclient
-PANDA_LIB_DEPENDS_OFF= libc-client4.so.9:mail/cclient
+LIB_DEPENDS+= libc-client.so.2010:mail/panda-cclient
CONFIGURE_ARGS+= --with-imap-ssl=${OPENSSLBASE} \
--with-imap=${LOCALBASE}
@@ -378,8 +375,8 @@ BUILD_DEPENDS= re2c:devel/re2c
.endif
.if ${PHP_MODNAME} == "ldap"
-CONFIGURE_ARGS+= --with-ldap-sasl=${LOCALBASE} \
- --with-ldap=${LOCALBASE}
+LIB_DEPENDS+=libsasl2.so:security/cyrus-sasl2
+CONFIGURE_ARGS+=--with-ldap=${LOCALBASE} --with-ldap-sasl=${LOCALBASE}
USES+= ldap
.endif
@@ -398,20 +395,13 @@ PHP_HEADER_DIRS= libmbfl libmbfl/filters libmbfl/mbfl libmbfl/nls
.endif
.if ${PHP_MODNAME} == "mysqli"
-OPTIONS_DEFINE= MYSQLND
-OPTIONS_DEFAULT= MYSQLND
-
-MYSQLND_DESC= Use MySQL Native Driver
-MYSQLND_CONFIGURE_ON= --with-mysqli=mysqlnd
-MYSQLND_CONFIGURE_OFF= --with-mysqli=${LOCALBASE}/bin/mysql_config
-MYSQLND_USES_OFF= mysql
+CONFIGURE_ARGS+= --with-mysqli
.endif
.if ${PHP_MODNAME} == "odbc"
LIB_DEPENDS+= libodbc.so:databases/unixODBC
-CONFIGURE_ARGS+= --enable-odbc \
- --with-unixODBC=${LOCALBASE}
+CONFIGURE_ARGS+= --with-unixODBC=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "opcache"
@@ -504,8 +494,8 @@ CONFIGURE_ARGS+= --with-pspell=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "readline"
-CONFIGURE_ARGS+= --with-readline=/usr
-USES+= readline
+CONFIGURE_ARGS+=--with-libedit
+USES+= libedit
.endif
.if ${PHP_MODNAME} == "session"
@@ -622,8 +612,7 @@ USE_PHP= dom:build xml:build
.if ${PHP_MODNAME} == "zip"
LIB_DEPENDS+= libzip.so:archivers/libzip
-CONFIGURE_ARGS+= --with-zip \
- --with-zlib-dir=/usr
+CONFIGURE_ARGS+= --with-zip
USES+= pkgconfig
.endif
diff --git a/lang/php83/distinfo b/lang/php83/distinfo
index 85b807cbb228..d6c31a4c1d21 100644
--- a/lang/php83/distinfo
+++ b/lang/php83/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1699700741
-SHA256 (php-8.3.0RC6.tar.xz) = 1e7b5dcfebc4921ec44209c1e08ae71b6b10e5b1b6b895bb4f76b44486c705ed
-SIZE (php-8.3.0RC6.tar.xz) = 12438800
+TIMESTAMP = 1700688940
+SHA256 (php-8.3.0.tar.xz) = 1db84fec57125aa93638b51bb2b15103e12ac196e2f960f0d124275b2687ea54
+SIZE (php-8.3.0.tar.xz) = 12431612
diff --git a/lang/php83/files/patch-ext_mysqli_mysqli__api.c b/lang/php83/files/patch-ext_mysqli_mysqli__api.c
deleted file mode 100644
index 535503954e3d..000000000000
--- a/lang/php83/files/patch-ext_mysqli_mysqli__api.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ext/mysqli/mysqli_api.c.orig 2020-09-29 22:36:51 UTC
-+++ ext/mysqli/mysqli_api.c
-@@ -29,7 +29,9 @@
- #include "zend_smart_str.h"
- #include "php_mysqli_structs.h"
- #include "mysqli_priv.h"
-+#if defined(MYSQLI_USE_MYSQLND)
- #include "ext/mysqlnd/mysql_float_to_double.h"
-+#endif
-
- #define ERROR_ARG_POS(arg_num) (getThis() ? (arg_num-1) : (arg_num))
-
diff --git a/lang/php83/files/patch-ext_mysqli_mysqli__nonapi.c b/lang/php83/files/patch-ext_mysqli_mysqli__nonapi.c
deleted file mode 100644
index 83d0d8dfc8cb..000000000000
--- a/lang/php83/files/patch-ext_mysqli_mysqli__nonapi.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ext/mysqli/mysqli_nonapi.c.orig 2022-08-02 13:57:03 UTC
-+++ ext/mysqli/mysqli_nonapi.c
-@@ -26,7 +26,9 @@
- #include "php_ini.h"
- #include "ext/standard/info.h"
- #include "zend_smart_str.h"
-+#if defined(MYSQLI_USE_MYSQLND)
- #include "php_mysqli_structs.h"
-+#endif
- #include "mysqli_priv.h"
- #define ERROR_ARG_POS(arg_num) (getThis() ? (arg_num-1) : (arg_num))
-
diff --git a/lang/php83/files/patch-ext_mysqli_mysqli__prop.c b/lang/php83/files/patch-ext_mysqli_mysqli__prop.c
deleted file mode 100644
index bc201d57981e..000000000000
--- a/lang/php83/files/patch-ext_mysqli_mysqli__prop.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ext/mysqli/mysqli_prop.c.orig 2022-08-02 13:57:03 UTC
-+++ ext/mysqli/mysqli_prop.c
-@@ -24,7 +24,9 @@
- #include "php.h"
- #include "php_ini.h"
- #include "ext/standard/info.h"
-+#if defined(MYSQLI_USE_MYSQLND)
- #include "php_mysqli_structs.h"
-+#endif
- #include "mysqli_priv.h"
-
- #define CHECK_STATUS(value, quiet) \
diff --git a/lang/php83/pkg-plist b/lang/php83/pkg-plist
index a01d7361c7c7..148b08bab605 100644
--- a/lang/php83/pkg-plist
+++ b/lang/php83/pkg-plist
@@ -167,13 +167,6 @@ include/php/ext/libxml/php_libxml.h
%%MYSQLND%%include/php/ext/mysqlnd/mysqlnd_vio.h
%%MYSQLND%%include/php/ext/mysqlnd/mysqlnd_wireprotocol.h
%%MYSQLND%%include/php/ext/mysqlnd/php_mysqlnd.h
-include/php/ext/pcre/pcre2lib/config.h
-include/php/ext/pcre/pcre2lib/pcre2.h
-include/php/ext/pcre/pcre2lib/pcre2_internal.h
-include/php/ext/pcre/pcre2lib/pcre2_intmodedep.h
-include/php/ext/pcre/pcre2lib/pcre2_jit_neon_inc.h
-include/php/ext/pcre/pcre2lib/pcre2_jit_simd_inc.h
-include/php/ext/pcre/pcre2lib/pcre2_ucp.h
include/php/ext/pcre/php_pcre.h
include/php/ext/random/php_random.h
include/php/ext/spl/php_spl.h