aboutsummaryrefslogtreecommitdiff
path: root/lang/pike72
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2005-01-31 00:35:55 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2005-01-31 00:35:55 +0000
commit34fa6c853efa04ca648d3d4187d4aec40a00fc0d (patch)
tree3445b3e9b6e7650fd127ec078394a0d7a8e79076 /lang/pike72
parentae2c26ad44dba87dd1377d70dfb1906132114c7b (diff)
downloadports-34fa6c853efa04ca648d3d4187d4aec40a00fc0d.tar.gz
ports-34fa6c853efa04ca648d3d4187d4aec40a00fc0d.zip
Split the postgresql ports into a server and a client part.
All ports depending on postgresql shall use the USE_PGSQL=yes knob defined in Mk/bsd.ports.mk. Bumping portrevisions where needed. PR: 75344 Approved by: portmgr@ (kris), ade & sean (mentors)
Notes
Notes: svn path=/head/; revision=127737
Diffstat (limited to 'lang/pike72')
-rw-r--r--lang/pike72/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
index 0e101f698b01..459efc7f967d 100644
--- a/lang/pike72/Makefile
+++ b/lang/pike72/Makefile
@@ -75,7 +75,7 @@ WITH_FREETYPE= yes
WITH_MYSQL= yes
.endif
-.if exists(${LOCALBASE}/lib/libpq.so.2)
+.if exists(${LOCALBASE}/lib/libpq.so)
WITH_POSTGRES= yes
.endif
@@ -130,7 +130,7 @@ CONFIGURE_ARGS+= --without-mysql
.endif
.if defined(WITH_POSTGRES)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+USE_PGSQL= yes
CONFIGURE_ARGS+= --with-pgsql=${PREFIX}
.else
CONFIGURE_ARGS+= --without-pgsql