aboutsummaryrefslogtreecommitdiff
path: root/lang/polyml/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-03-29 14:05:30 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-03-29 14:05:30 +0000
commitf2eb9abe3634a5cfb4e33d02b4cd400fd5777c5c (patch)
tree4c63d72c44c792798ff532a107c715e7ef780e2c /lang/polyml/Makefile
parent8af4a7bd4e81ec7d6bf08be4c1e7492c12a2c1b1 (diff)
downloadports-f2eb9abe3634a5cfb4e33d02b4cd400fd5777c5c.tar.gz
ports-f2eb9abe3634a5cfb4e33d02b4cd400fd5777c5c.zip
- Update to 4.2.0
- Is not RESTRICTED anymore PR: 94667 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=158386
Diffstat (limited to 'lang/polyml/Makefile')
-rw-r--r--lang/polyml/Makefile71
1 files changed, 29 insertions, 42 deletions
diff --git a/lang/polyml/Makefile b/lang/polyml/Makefile
index 45adbb8279f9..b9faa033597a 100644
--- a/lang/polyml/Makefile
+++ b/lang/polyml/Makefile
@@ -6,68 +6,55 @@
#
PORTNAME= polyml
-PORTVERSION= 4.1.3
+PORTVERSION= 4.2.0
CATEGORIES= lang
-DISTFILES= polyml-driver-4.1.3.tar.gz \
- polyml-mlsource-4.1.3.tar.gz \
- polyml-basis-4.1.3.tar.gz \
- polyml-4.1.3.i386.tar.gz
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= driver.420.tar.gz \
+ mlsource.420.tar.gz \
+ basis.420.tar.gz \
+ DB420.i386.unix.gz
DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= driver.420.tar.gz \
+ mlsource.420.tar.gz \
+ basis.420.tar.gz
MAINTAINER= timbob@bigpond.com
COMMENT= Fast open-source implementation of Standard ML
WRKSRC= ${WRKDIR}/driver
+
ONLY_FOR_ARCHS= i386
+
+USE_GCC= 3.2+
HAS_CONFIGURE= yes
CONFIGURE_ARGS= ${PREFIX}
-SUB_FILES= poly pkg-message
+SUB_FILES= poly
PLIST_FILES= bin/poly \
lib/polyml/poly \
- lib/polyml/LICENCE \
+ lib/polyml/COPYING \
lib/polyml/ML_dbase \
- lib/polyml/DB413Release
+ lib/polyml/DB420.i386.unix
PLIST_DIRS= lib/polyml
-RESTRICTED= Downloading implies agreement to the licence.
-
NO_INSTALL_MANPAGES=yes
-.include <bsd.port.pre.mk>
-TO_BE_FETCHED=
+post-extract:
+ @${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/DB420.i386.unix.gz \
+ > ${WRKDIR}/DB420.i386.unix
-.for f in ${DISTFILES}
-.if ! exists (${DISTDIR}/${DIST_SUBDIR}/${f})
-TO_BE_FETCHED+= ${f}
-.endif
-.endfor
-
-do-fetch:
-.if ${TO_BE_FETCHED} != ""
-ECHO_MSG=/usr/bin/printf
-IGNORE= :\n\n\
-------------------------------------------------------------------\n\
-Downloading this software implies acceptance of the licence\n\
-agreement, which may be found at: http://www.polyml.org/Get.html\n\
-\n\
-Please download the following files into ${DISTDIR}/${DIST_SUBDIR}\n\
-\n
-.for f in ${TO_BE_FETCHED}
-IGNORE+= ${f}\n
-.endfor
-IGNORE+=------------------------------------------------------------------\n\n
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s|gcc|${CC}|g" ${WRKSRC}/configure
post-build:
(cd ${WRKDIR}/mlsource/MLCompiler/CodeTree; ${LN} -fs CodeCons.i386 CodeCons)
- (cd ${WRKDIR}; ./driver/poly ML_dbase < mlsource/BuildAll.sml)
+ (cd ${WRKDIR}; ./driver/poly DB420.i386.unix < mlsource/BuildAll.sml)
post-install:
- @${INSTALL_DATA} ${WRKDIR}/DB413Release ${PREFIX}/lib/polyml/
- @${INSTALL_SCRIPT} ${WRKDIR}/poly ${PREFIX}/bin/poly
- (cd ${PREFIX}/lib/polyml; ${LN} -fs ./DB413Release ML_dbase)
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_DATA} ${WRKDIR}/DB420.i386.unix ${PREFIX}/lib/polyml/
+ ${INSTALL_SCRIPT} ${WRKDIR}/poly ${PREFIX}/bin/poly
+ @(cd ${PREFIX}/lib/polyml; ${LN} -fs ./DB420.i386.unix ML_dbase)
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
install-user:
@@ -80,9 +67,9 @@ install-user:
@${ECHO_CMD} "User copy of database already exists. Aborting!"
@${ECHO_CMD}
.else
- ${MKDIR} ${HOME}/.polyml
- ${CP} ${LOCALBASE}/lib/polyml/ML_dbase ${HOME}/.polyml
- ${CHMOD} 0600 ${HOME}/.polyml/ML_dbase
+ @${MKDIR} ${HOME}/.polyml
+ @${CP} ${LOCALBASE}/lib/polyml/ML_dbase ${HOME}/.polyml
+ @${CHMOD} 0600 ${HOME}/.polyml/ML_dbase
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>