aboutsummaryrefslogtreecommitdiff
path: root/lang/polyml/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-10-23 17:24:12 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-10-23 17:24:12 +0000
commitfa07ac670c58c5e1d412ac9e778e6c09057024e0 (patch)
tree088c2f3ebb9901d41316947adfd085b396d94825 /lang/polyml/Makefile
parent6f930a4ab101c7dda64b6a13c1e06d59a535a9db (diff)
downloadports-fa07ac670c58c5e1d412ac9e778e6c09057024e0.tar.gz
ports-fa07ac670c58c5e1d412ac9e778e6c09057024e0.zip
- Allow exposing polyml as a shared library (as required by e.g. HOL4)
- Strip installed library as advised by portlint(1) - While here, sort knobs and remove useless .include <bsd.port.options.mk> PR: 203467 Approved by: maintainer
Notes
Notes: svn path=/head/; revision=400041
Diffstat (limited to 'lang/polyml/Makefile')
-rw-r--r--lang/polyml/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/lang/polyml/Makefile b/lang/polyml/Makefile
index 4a2fc80a262e..0b52968b0a3f 100644
--- a/lang/polyml/Makefile
+++ b/lang/polyml/Makefile
@@ -3,7 +3,7 @@
PORTNAME= polyml
PORTVERSION= 5.5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= SF
DISTNAME= ${PORTNAME}.${PORTVERSION}
@@ -16,20 +16,22 @@ LICENSE= LGPL21
LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
+ONLY_FOR_ARCHS= i386 amd64
+
+USES= libtool pathfix pkgconfig
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-system-libffi
-USES= libtool pkgconfig pathfix
+CONFIGURE_ARGS= --with-system-libffi --enable-shared
USE_LDCONFIG= yes
-ONLY_FOR_ARCHS= i386 amd64
-OPTIONS_DEFINE= MOTIF
+INSTALL_TARGET= install-strip
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= MOTIF
MOTIF_CONFIGURE_WITH= x
MOTIF_USE= motif
-pre-build:
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lstdc++ ||' ${WRKSRC}/configure
@${REINPLACE_CMD} "s|ELFXX_R_INFO(_y, _z) ELF64_R_INFO(_y, _z)|ELFXX_R_INFO(_y, _z) ELF64_R_INFO((Elf64_Xword)(_y), _z)|g" ${WRKSRC}/libpolyml/elfexport.h
.include <bsd.port.mk>