aboutsummaryrefslogtreecommitdiff
path: root/lang/ptoc
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2018-05-14 21:03:47 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2018-05-14 21:03:47 +0000
commit1b779b3b3ab63afcf8bf73a8024d7aefbd283e11 (patch)
treedfa265519dd01c0f4ad7a8d47d77e2fab752c848 /lang/ptoc
parentfa1749b609dbdb82f39ce29b4a645a55e51d31e3 (diff)
downloadports-1b779b3b3ab63afcf8bf73a8024d7aefbd283e11.tar.gz
ports-1b779b3b3ab63afcf8bf73a8024d7aefbd283e11.zip
Fix build with clang 6.0.
Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=469968
Diffstat (limited to 'lang/ptoc')
-rw-r--r--lang/ptoc/Makefile1
-rw-r--r--lang/ptoc/files/patch-makefile.bsd40
2 files changed, 39 insertions, 2 deletions
diff --git a/lang/ptoc/Makefile b/lang/ptoc/Makefile
index 3064b95b59ee..3c978e6eaf1a 100644
--- a/lang/ptoc/Makefile
+++ b/lang/ptoc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ptoc
PORTVERSION= 3.58
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.garret.ru/
diff --git a/lang/ptoc/files/patch-makefile.bsd b/lang/ptoc/files/patch-makefile.bsd
index aa2d6a57d30e..f84d2eb2cf05 100644
--- a/lang/ptoc/files/patch-makefile.bsd
+++ b/lang/ptoc/files/patch-makefile.bsd
@@ -1,5 +1,41 @@
---- makefile.bsd.orig Sat Nov 7 10:10:50 1998
-+++ makefile.bsd Sat Oct 21 05:54:55 2000
+--- makefile.bsd.orig 1998-11-06 21:10:50.000000000 -0500
++++ makefile.bsd 2018-05-14 12:46:15.288108000 -0400
+@@ -10,21 +10,21 @@
+ #
+ # C/C++ compiler
+ #
+-CC?= gcc
+-CXX?= g++
++CC?= cc
++CXX?= c++
+
+ #
+ # C/C++ flags
+ #
+-CFLAGS?= -O5 -g -Wall -c
+-CXXFLAGS?= -O5 -g -Wall -c
++CFLAGS?= -Wall -c
++CXXFLAGS= -Wall -c -std=c++98
+ #CFLAGS= -fno-exceptions -O5 -g -Wall -c
+ #CXXFLAGS= -fno-exceptions -O5 -g -Wall -c
+
+ #
+ # X Window System directory
+ #
+-X11BASE?= /usr/X11R6
++X11BASE?= /usr/local
+
+ #
+ # Local packages directory
+@@ -94,7 +94,7 @@
+ $(CXX) $(CXXFLAGS) $(DEFINES) $(INCLUDES) -o $@ -c $<
+
+ .c.o :
+- $(CC) $(CXXFLAGS) $(DEFINES) $(INCLUDES) -o $@ -c $<
++ $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) -o $@ -c $<
+
+ #
+ # Custom targets.
@@ -131,7 +131,7 @@
$(LD) $(LDFLAGS) -o $@ $(OBJS)