aboutsummaryrefslogtreecommitdiff
path: root/lang/py-mx-base/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-03 16:07:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-03 16:07:44 +0000
commit5406fe5c8ab84f8a1cb3c67b5fb2cf6e8d039025 (patch)
treeebe5a848b7b5d7531b1c482310307b6bd83efdac /lang/py-mx-base/Makefile
parentd9a1b61c4e417e74d0b1c0b1c10d15be783d419c (diff)
downloadports-5406fe5c8ab84f8a1cb3c67b5fb2cf6e8d039025.tar.gz
ports-5406fe5c8ab84f8a1cb3c67b5fb2cf6e8d039025.zip
- Update to 3.2.3
PR: 166961 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
Notes
Notes: svn path=/head/; revision=295965
Diffstat (limited to 'lang/py-mx-base/Makefile')
-rw-r--r--lang/py-mx-base/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/lang/py-mx-base/Makefile b/lang/py-mx-base/Makefile
index 1ae67e2e3b2e..be9ba095e9c2 100644
--- a/lang/py-mx-base/Makefile
+++ b/lang/py-mx-base/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= mx-base
-PORTVERSION= 3.1.3
+PORTVERSION= 3.2.3
CATEGORIES= lang python
MASTER_SITES= http://downloads.egenix.com/python/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= egenix-${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= 5u623l20@gmail.com
COMMENT= The eGenix mx-Extension Series for Python
USE_PYTHON= yes
@@ -23,12 +23,17 @@ USE_ZOPE= yes
PYDISTUTILS_PKGNAME= egenix-mx-base
-DOCDIR= ${PREFIX}/share/doc/py-mx
+PORTDOCS= COPYRIGHT MANIFEST README LICENSE PKG-INFO
post-install:
- @${MKDIR} ${DOCDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
@${SED} -e "s;%%PYTHON_SITELIBDIR%%;${PYTHON_SITELIBDIR};g" \
- < ${FILESDIR}/index.html.in > ${DOCDIR}/index.html
- @${CHMOD} 644 ${DOCDIR}/index.html
+ < ${FILESDIR}/index.html.in > ${DOCSDIR}/index.html
+ @${CHMOD} 644 ${DOCSDIR}/index.html
+.endif
.include <bsd.port.mk>