aboutsummaryrefslogtreecommitdiff
path: root/lang/py-mx-base/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-06-16 07:38:43 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-06-16 07:38:43 +0000
commit9277bdc6a2e8c741cd70d736c9445546af4127d2 (patch)
tree44c289cb47f47f17d15a7d0317e611b99cb68d2a /lang/py-mx-base/Makefile
parent8f418b90ca142d64d2b656efc1a17201a682e5cf (diff)
downloadports-9277bdc6a2e8c741cd70d736c9445546af4127d2.tar.gz
ports-9277bdc6a2e8c741cd70d736c9445546af4127d2.zip
Make this actually work. Fix MASTER_SITES while I'm here.
PR: 19259 Submitted by: Dominic Mitchell <hdm@mistral.co.uk>
Notes
Notes: svn path=/head/; revision=29625
Diffstat (limited to 'lang/py-mx-base/Makefile')
-rw-r--r--lang/py-mx-base/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/lang/py-mx-base/Makefile b/lang/py-mx-base/Makefile
index aabb493d163c..9b573bbd2e3d 100644
--- a/lang/py-mx-base/Makefile
+++ b/lang/py-mx-base/Makefile
@@ -8,7 +8,7 @@
PORTNAME= py-mxTextTools
PORTVERSION= 1.1.1
CATEGORIES= textproc python
-MASTER_SITES= http://starship.skyport.net/~lemburg/
+MASTER_SITES= http://starship.python.net/~lemburg/
DISTNAME= mxTextTools-1.1.1
MAINTAINER= tg@FreeBSD.org
@@ -32,11 +32,15 @@ post-extract:
do-configure:
@(cd ${WRKSRC} && ${CONFIGURE_ENV} ${MAKE} -f Makefile.pre.in boot)
-post-install:
+do-install:
@${MKDIR} ${TEXTTOOLSDIR}
${INSTALL_DATA} ${WRKDIR}/TextTools/*.py ${TEXTTOOLSDIR}
@${MKDIR} ${TEXTTOOLSDIR}/Constants
${INSTALL_DATA} ${WRKDIR}/TextTools/Constants/*.py ${TEXTTOOLSDIR}/Constants
+ @${MKDIR} ${TEXTTOOLSDIR}/mxTextTools
+.for file in __init__.py mxTextTools.so
+ ${INSTALL_DATA} ${WRKDIR}/TextTools/mxTextTools/${file} ${TEXTTOOLSDIR}/mxTextTools
+.endfor
@${PREFIX}/bin/python ${PYTHONSCRIPTDIR}/compileall.py ${TEXTTOOLSDIR}
@${PREFIX}/bin/python -O ${PYTHONSCRIPTDIR}/compileall.py ${TEXTTOOLSDIR}
@${MKDIR} ${EXAMPLEDIR}