aboutsummaryrefslogtreecommitdiff
path: root/lang/python24
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2000-01-13 13:28:10 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2000-01-13 13:28:10 +0000
commit66082ac2d09bc60c078da3d0477b4787838c329d (patch)
tree38449f09961e6ff06a43b3bda907d1cc139ac468 /lang/python24
parent38b1a6fd25e50622548241d8a1349d6e5416b321 (diff)
downloadports-66082ac2d09bc60c078da3d0477b4787838c329d.tar.gz
ports-66082ac2d09bc60c078da3d0477b4787838c329d.zip
- Support IPv6.
- remove DIST_SUBDIR since there are 2 distfiles on this port anymore. Reviewed by: tg(maintainer)
Notes
Notes: svn path=/head/; revision=24697
Diffstat (limited to 'lang/python24')
-rw-r--r--lang/python24/Makefile19
-rw-r--r--lang/python24/distinfo3
-rw-r--r--lang/python24/pkg-plist1
3 files changed, 20 insertions, 3 deletions
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index d8f497196ca8..108a8abb6224 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -13,14 +13,22 @@ MASTER_SITES= ftp://www.python.org/pub/python/src/ \
ftp://ftp.cwi.nl/pub/python/src/
EXTRACT_SUFX= .tgz
+PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/
+PATCHFILES= python-152-v6-20000113.diff.gz
+PATCH_DIST_STRIP= -p1
+
MAINTAINER= tg@FreeBSD.org
LIB_DEPENDS= ${TK_DEPENDS}
-DIST_SUBDIR= python
WRKSRC= ${WRKDIR}/Python-1.5.2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-fpectl --with-libs='-lxpg4'
+.if defined(USE_INET6)
+CONFIGURE_ARGS+=--enable-ipv6
+.else
+CONFIGURE_ARGS+=--disable-ipv6
+.endif
CONFIGURE_ENV= OPT="${CFLAGS}"
INSTALL_TARGET= install
PLIST= ${WRKDIR}/PLIST
@@ -54,6 +62,7 @@ WITH_THREADS?= yes
LIBC_R!= /sbin/ldconfig -r | grep c_r || true
.if ${LIBC_R} != "" && defined(WITH_THREADS) && ${WITH_THREADS} == yes
CONFIGURE_ARGS+= --with-thread
+
CFLAGS+= -D_THREAD_SAFE
CONFIGURE_ENV+= LDFLAGS="-pthread ${LDFLAGS}"
.endif
@@ -75,6 +84,9 @@ WITH_TOOLS?= yes
.if defined(WITH_TOOLS) && ${WITH_TOOLS} == yes
PLIST_TOOLS= ${PKGDIR}/PLIST.Tools
.endif
+.if defined(USE_INET6)
+PLIST_V6= ${PKGDIR}/PLIST.v6
+.endif
post-extract:
cd ${WRKSRC}/Lib && ${SH} ${FILESDIR}/plat-freebsd4.sh
@@ -101,7 +113,7 @@ pre-install:
${INSTALL_DATA} ${WRKSRC}/Lib/${platform}/* \
${PREFIX}/lib/python1.5/${platform}/
.endfor
- @sort -r -o ${PLIST} ${PLIST_TK} ${PLIST_GMP} ${PLIST_TOOLS} ${PKGDIR}/PLIST
+ @sort -r -o ${PLIST} ${PLIST_TK} ${PLIST_GMP} ${PLIST_TOOLS} ${PLIST_V6} ${PKGDIR}/PLIST
post-install:
strip ${PREFIX}/bin/python
@@ -114,5 +126,8 @@ post-install:
@cd ${WRKSRC}; tar cf - Tools | \
(cd ${PREFIX}/lib/python1.5; tar xf -)
.endif
+.if defined(USE_INET6)
+ ${INSTALL_DATA} ${WRKSRC}/README.v6 ${PREFIX}/share/doc/python
+.endif
.include <bsd.port.post.mk>
diff --git a/lang/python24/distinfo b/lang/python24/distinfo
index 72ca6a75cf6c..f3530a2ebfa8 100644
--- a/lang/python24/distinfo
+++ b/lang/python24/distinfo
@@ -1 +1,2 @@
-MD5 (python/py152.tgz) = e9d677ae6d5a3efc6937627ed8a3e752
+MD5 (py152.tgz) = e9d677ae6d5a3efc6937627ed8a3e752
+MD5 (python-152-v6-20000113.diff.gz) = 9f130f18402d4731287db54acdf7a01f
diff --git a/lang/python24/pkg-plist b/lang/python24/pkg-plist
index 58ef1c97477d..22ee7513f4ab 100644
--- a/lang/python24/pkg-plist
+++ b/lang/python24/pkg-plist
@@ -4,6 +4,7 @@ share/doc/python/COPYRIGHT
share/emacs/site-lisp/python-mode.el
include/python1.5/Python.h
include/python1.5/abstract.h
+include/python1.5/addrinfo.h
include/python1.5/bitset.h
include/python1.5/bufferobject.h
include/python1.5/cStringIO.h