aboutsummaryrefslogtreecommitdiff
path: root/lang/python25/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-11-24 15:12:44 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-11-24 15:12:44 +0000
commit3876bae11fc3c661e737defadeba172653b29587 (patch)
treeba2306ca4a84f4937e64356ad5218827c0a9662a /lang/python25/Makefile
parent3bd19ba4150cd93b5beb552575fc27c86253d050 (diff)
downloadports-3876bae11fc3c661e737defadeba172653b29587.tar.gz
ports-3876bae11fc3c661e737defadeba172653b29587.zip
Use an option to disable the Tk extension (WITH_TK). Don't use
libc_r if we're not building the thread module. Respect options given in the environment. The defaults (build with Tk and thread support) don't change.
Notes
Notes: svn path=/head/; revision=8799
Diffstat (limited to 'lang/python25/Makefile')
-rw-r--r--lang/python25/Makefile31
1 files changed, 25 insertions, 6 deletions
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 74dccf93bca3..387b83d84d3a 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -3,7 +3,7 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.16 1997/08/06 06:40:27 tg Exp $
+# $Id: Makefile,v 1.17 1997/08/29 07:04:17 tg Exp $
#
DISTNAME= python1.4
@@ -13,11 +13,11 @@ MASTER_SITES= ftp://www.python.org/pub/python/src/ \
ftp://ftp.cwi.nl/pub/python/src/ \
ftp://www.python.org/pub/python/contrib/Graphics/Tkinter/ \
ftp://ftp.cwi.nl/pub/python/contrib/Graphics/Tkinter/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} _tkinter1.4.c
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${TKINTER}
MAINTAINER= tg@FreeBSD.org
-LIB_DEPENDS= tk80\\.1\\.:${PORTSDIR}/x11/tk80
+LIB_DEPENDS= ${TK_DEPENDS}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
WRKSRC= ${WRKDIR}/Python-1.4
@@ -28,22 +28,41 @@ INSTALL_TARGET= install
MAN1= python.1
#
+# The standard setup file
+#
+SETUP_FILE= Setup
+
+#
+# Support for Tk is compiled in by default.
+#
+WITH_TK?= yes
+.if defined(WITH_TK) && $(WITH_TK) == yes
+TK_DEPENDS= tk80\\.1\\.:${PORTSDIR}/x11/tk80
+TKINTER= _tkinter1.4.c
+SETUP_LOCAL+= Setup.tk
+.endif
+
+#
# If you want to use Python's thread module, you need to set WITH_THREADS
# to 'yes', and you must have the FreeBSD threading c library (libc_r)
# installed. See 'man 3 pthread' for details on libc_r.
#
-WITH_THREADS= yes
-SETUP_FILE= Setup
+WITH_THREADS?= yes
.if exists(/usr/lib/libc_r.a) && defined(WITH_THREADS) && ${WITH_THREADS} == yes
CONFIGURE_ARGS+= --with-thread
-SETUP_FILE= Setup.thread
+SETUP_LOCAL+= Setup.thread
.endif
post-extract:
+.if defined(WITH_TK) && $(WITH_TK) == yes
${CP} ${DISTDIR}/_tkinter1.4.c ${WRKSRC}/Modules/_tkinter.c
+.endif
post-configure:
${CP} ${FILESDIR}/${SETUP_FILE} ${WRKSRC}/Modules/Setup
+.for file in ${SETUP_LOCAL}
+ ${CAT} ${FILESDIR}/${file} >> ${WRKSRC}/Modules/Setup.local
+.endfor
post-install:
strip ${PREFIX}/bin/python