aboutsummaryrefslogtreecommitdiff
path: root/lang/python25/Makefile
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1995-08-08 22:09:07 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1995-08-08 22:09:07 +0000
commit9b2f64d7769515d85770f1693959a5e4664c94e3 (patch)
tree39e63adc7c6c41070ede3693e4ddb43498043a08 /lang/python25/Makefile
parent34750bc348aea2923fe5b1a143357ad9c3803109 (diff)
downloadports-9b2f64d7769515d85770f1693959a5e4664c94e3.tar.gz
ports-9b2f64d7769515d85770f1693959a5e4664c94e3.zip
The Python programming language.
Notes
Notes: svn path=/head/; revision=2042
Diffstat (limited to 'lang/python25/Makefile')
-rw-r--r--lang/python25/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
new file mode 100644
index 000000000000..a8ea89a2cc8d
--- /dev/null
+++ b/lang/python25/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: python
+# Version required: 1.2
+# Date created: 08 August 1995
+# Whom: jkh
+#
+# $Id$
+#
+
+DISTNAME= python1.2
+CATEGORIES+= languages
+MASTER_SITES= ftp://www.python.org/pub/python/src/
+
+MAINTAINER= jkh@FreeBSD.org
+WRKSRC= ${WRKDIR}/Python-1.2
+HAS_CONFIGURE= yes
+
+LIB_DEPENDS= tcl\\.7\\.:${PORTSDIR}/lang/tcl \
+ tk\\.3\\.:${PORTSDIR}/x11/tk
+
+post-configure:
+ cp ${FILESDIR}/Setup ${WRKSRC}/Modules
+
+pre-install:
+ cd ${WRKSRC}; ${MAKE} libinstall
+
+.include <bsd.port.mk>