aboutsummaryrefslogtreecommitdiff
path: root/lang/python27/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-12-29 12:03:09 +0000
committerJohn Marino <marino@FreeBSD.org>2015-12-29 12:03:09 +0000
commit6256117d69833c86052b33bbc7252a244d3413a7 (patch)
tree442cd87d41f98356b818e916797bd629171b005c /lang/python27/Makefile
parent5181935100e044b96a86b4671e62ec0692fa2c27 (diff)
downloadports-6256117d69833c86052b33bbc7252a244d3413a7.tar.gz
ports-6256117d69833c86052b33bbc7252a244d3413a7.zip
lang/python27(3*), Mk/Uses/python.mk: remove make spawn
There are some inefficiencies in python.mk that significantly slow down full tree scanning. The use of bmake to obtain the current version of a specific python is responsible for the majority of the slow done. This commit splits out the PYTHON_PORTVERSION definition (which is the same as the lang/python* PORTVERSION) into separate files. With this change, python.mk can simple include the makefile fragment instead of spawning a new instance of make. Different Revision: https://reviews.freebsd.org/D4660 Approved by: antoine (python), mva (python)
Notes
Notes: svn path=/head/; revision=404739
Diffstat (limited to 'lang/python27/Makefile')
-rw-r--r--lang/python27/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index d8b9a506c915..70190f5185ab 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= python27
-PORTVERSION= 2.7.11
+PORTVERSION= ${PYTHON_PORTVERSION}
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -73,6 +73,7 @@ THREADS_LDFLAGS= -lpthread
UCS2_CONFIGURE_ON= --enable-unicode=ucs2
UCS4_CONFIGURE_ON= --enable-unicode=ucs4
+.include "${.CURDIR}/Makefile.version"
.include <bsd.port.options.mk>
# http://bugs.python.org/issue22521