aboutsummaryrefslogtreecommitdiff
path: root/lang/python27/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-06 06:32:22 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-06 06:32:22 +0000
commit7cdc62b981ecfcc26a72eb00e704f0180853de99 (patch)
tree9e0e39ea77f4f75a3e4e404bd0bbbe59e137f66c /lang/python27/Makefile
parentc54b783cab509fc7826a56aff6e5728e5036c17a (diff)
downloadports-7cdc62b981ecfcc26a72eb00e704f0180853de99.tar.gz
ports-7cdc62b981ecfcc26a72eb00e704f0180853de99.zip
- adoption of USES for gettext
Approved by: portmgr (bapt@)
Notes
Notes: svn path=/head/; revision=317469
Diffstat (limited to 'lang/python27/Makefile')
-rw-r--r--lang/python27/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index fb4b92fc0f43..5f8fb7e25a5b 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -58,6 +58,17 @@ OPTIONS_SINGLE_UCS= UCS2 UCS4
NLS_DESC= Enable Gettext support for the locale module
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
+.else
+CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
+.endif
+
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MSEM}
@@ -80,15 +91,6 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
-# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
-#LDFLAGS+= "-L${LOCALBASE}/lib"
-#CFLAGS+= "-I${LOCALBASE}/include"
-.else
-CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
-.endif
-
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
.if ${PORT_OPTIONS:MPTH}