aboutsummaryrefslogtreecommitdiff
path: root/lang/python30
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1999-02-22 19:06:07 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1999-02-22 19:06:07 +0000
commitf21d8205f62652dfd86497df3ff0dcbbf3e43ca7 (patch)
tree0916cd7c47bf0cadb052a6fe56e6c88ba21a5895 /lang/python30
parent1e8b28510e160ee76ec8573c672cf4f2cc7c0058 (diff)
downloadports-f21d8205f62652dfd86497df3ff0dcbbf3e43ca7.tar.gz
ports-f21d8205f62652dfd86497df3ff0dcbbf3e43ca7.zip
Fix for building/packaging on FreeBSD 4.x.
Notes
Notes: svn path=/head/; revision=16859
Diffstat (limited to 'lang/python30')
-rw-r--r--lang/python30/Makefile25
-rw-r--r--lang/python30/pkg-plist13
2 files changed, 29 insertions, 9 deletions
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index f9311ace588b..e050eef23e78 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -3,7 +3,7 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.42 1998/12/02 08:24:49 asami Exp $
+# $Id: Makefile,v 1.44 1999/02/18 09:37:34 thepish Exp $
#
DISTNAME= pyth151
@@ -76,7 +76,8 @@ PLIST_GMP= lib/python1.5/lib-dynload/mpzmodule.so
post-extract:
cd ${WRKSRC}/Lib; ${SH} ${FILESDIR}/plat-freebsd2.sh; \
- ${SH} ${FILESDIR}/plat-freebsd3.sh
+ ${SH} ${FILESDIR}/plat-freebsd3.sh; \
+ ${SH} ${FILESDIR}/plat-freebsd4.sh
post-configure:
${CP} ${FILESDIR}/${SETUP_FILE} ${WRKSRC}/Modules/Setup
@@ -91,14 +92,20 @@ LDFLAGS+= -rdynamic
CONFIGURE_ENV?= LDFLAGS="${LDFLAGS}"
.endif
-pre-install:
-.if ${OSVERSION} < 300000
- ${MKDIR} ${PREFIX}/lib/python1.5/plat-freebsd3
- ${INSTALL_DATA} ${WRKSRC}/Lib/plat-freebsd3/* ${PREFIX}/lib/python1.5/plat-freebsd3
-.else
- ${MKDIR} ${PREFIX}/lib/python1.5/plat-freebsd2
- ${INSTALL_DATA} ${WRKSRC}/Lib/plat-freebsd2/* ${PREFIX}/lib/python1.5/plat-freebsd2
+.if ${OSVERSION} >= 400000
+PLATFORMS=plat-freebsd2 plat-freebsd3
+.elif ${OSVERSION} >= 300000
+PLATFORMS=plat-freebsd2 plat-freebsd4
+.else
+PLATFORMS=plat-freebsd3 plat-freebsd4
.endif
+
+pre-install:
+ for platform in ${PLATFORMS}; do \
+ ${MKDIR} ${PREFIX}/lib/python1.5/$$platform; \
+ ${INSTALL_DATA} ${WRKSRC}/Lib/$$platform/* \
+ ${PREFIX}/lib/python1.5/$$platform/; \
+ done
@${ECHO} ${PLIST_GMP} | sort -r -o ${PLIST} - ${PKGDIR}/PLIST
post-install:
diff --git a/lang/python30/pkg-plist b/lang/python30/pkg-plist
index b295c65ed685..b9658a589e3c 100644
--- a/lang/python30/pkg-plist
+++ b/lang/python30/pkg-plist
@@ -489,6 +489,19 @@ lib/python1.5/plat-freebsd3/TERMIOS.py
lib/python1.5/plat-freebsd3/TERMIOS.pyc
lib/python1.5/plat-freebsd3/TERMIOS.pyo
lib/python1.5/plat-freebsd3/regen
+lib/python1.5/plat-freebsd4/FCNTL.py
+lib/python1.5/plat-freebsd4/FCNTL.pyc
+lib/python1.5/plat-freebsd4/FCNTL.pyo
+lib/python1.5/plat-freebsd4/IN.py
+lib/python1.5/plat-freebsd4/IN.pyc
+lib/python1.5/plat-freebsd4/IN.pyo
+lib/python1.5/plat-freebsd4/SOCKET.py
+lib/python1.5/plat-freebsd4/SOCKET.pyc
+lib/python1.5/plat-freebsd4/SOCKET.pyo
+lib/python1.5/plat-freebsd4/TERMIOS.py
+lib/python1.5/plat-freebsd4/TERMIOS.pyc
+lib/python1.5/plat-freebsd4/TERMIOS.pyo
+lib/python1.5/plat-freebsd4/regen
lib/python1.5/poly.py
lib/python1.5/poly.pyc
lib/python1.5/poly.pyo