aboutsummaryrefslogtreecommitdiff
path: root/lang/python310/Makefile
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2021-09-27 17:39:05 +0000
committerDimitry Andric <dim@FreeBSD.org>2021-09-27 17:56:59 +0000
commit6bef09666460fb9f9052550854fa69f5d5e4a0e8 (patch)
treed7323851d190ce5e250f827559fcc9a0e1606da8 /lang/python310/Makefile
parent0e6da3c2e1f0ca151be9e6428dcc9c0b7f19d170 (diff)
downloadports-6bef09666460fb9f9052550854fa69f5d5e4a0e8.tar.gz
ports-6bef09666460fb9f9052550854fa69f5d5e4a0e8.zip
lang/python3([6-9]|10): disable detection of multiarch
It breaks with clang >= 13, which adds a major.minor version number in -print-multiarch output, and the dot confuses Python: ModuleNotFoundError: No module named '_sysconfigdata__freebsd14_x86_64-unknown-freebsd14' Since we do not support multiarch, and the configure script has no way to disable the multiarch check, stub it out during post-patch. PR: 258377 Approved by: maintainer timeout (2 weeks) MFH: 2021Q3
Diffstat (limited to 'lang/python310/Makefile')
-rw-r--r--lang/python310/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/python310/Makefile b/lang/python310/Makefile
index 3dbf8d5d004e..64aba656d340 100644
--- a/lang/python310/Makefile
+++ b/lang/python310/Makefile
@@ -124,6 +124,10 @@ post-patch:
# which introduces hidden dependency and breaks build
@${REINPLACE_CMD} -e 's|uuid/uuid.h|ignore_&|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/find_library_file/ s|uuid|ignore_&|' ${WRKSRC}/setup.py
+# disable detection of multiarch as it breaks with clang >= 13, which adds a
+# major.minor version number in -print-multiarch output, confusing Python
+ @${REINPLACE_CMD} -e 's|^MULTIARCH=.*|MULTIARCH=|' ${WRKSRC}/configure \
+ ${WRKSRC}/configure.ac
# Apply DISABLED_EXTENSIONS
@${ECHO_CMD} '*disabled*' > ${WRKSRC}/Modules/Setup.local
. for _module in ${DISABLED_EXTENSIONS}