aboutsummaryrefslogtreecommitdiff
path: root/lang/python310
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-10-13 16:48:56 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-10-13 17:05:40 +0000
commit693abe1cb40ba9f505b2c72497443ca3ce85887d (patch)
tree90835d15da020887a2bd09adc049ecb2d46769e7 /lang/python310
parentc2c3dc30c39fa6b433993ff7365d0b23e4becdb1 (diff)
downloadports-693abe1cb40ba9f505b2c72497443ca3ce85887d.tar.gz
ports-693abe1cb40ba9f505b2c72497443ca3ce85887d.zip
lang/python3X: Fix library installation
The Python ports install the library libpython3.x.so under $PREFIX/lib, and they set USE_LDCONFIG, but these libraries are not registered, due to a missing symlink, and they are not found by `ldconfig -r'. This commit make them to be registered, and for some reason it helps the dynamic linker to find them, and this allows to fix an error in french/aster. It also helps to fix errors in newer releases of math/sage (not yet ready to be committed due to other problems). No exp-run, but it has been tested with many ports on several platforms. PR: 257864 Approved by: koobs (Python team) MFH: 2021Q4
Diffstat (limited to 'lang/python310')
-rw-r--r--lang/python310/Makefile2
-rw-r--r--lang/python310/pkg-plist1
2 files changed, 3 insertions, 0 deletions
diff --git a/lang/python310/Makefile b/lang/python310/Makefile
index 508b194c02aa..c74cb102450a 100644
--- a/lang/python310/Makefile
+++ b/lang/python310/Makefile
@@ -2,6 +2,7 @@
PORTNAME= python
DISTVERSION= ${PYTHON_DISTVERSION}
+PORTREVISION= 1
CATEGORIES= lang python
MASTER_SITES= PYTHON/ftp/python/${DISTVERSION:C/[a-z].*//}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
@@ -138,6 +139,7 @@ post-install:
.if ! ${PORT_OPTIONS:MDEBUG}
${RM} ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: https://bugs.python.org/issue17975
.endif
+ ${LN} -sf libpython${PYTHON_VER}${ABIFLAGS}.so.1.0 ${STAGEDIR}${PREFIX}/lib/libpython${PYTHON_VER}${ABIFLAGS}.so.1
# This code block exists for the qemu-user enabled cross build environment.
# When using this environment in poudriere, CC is not set to the default
# of /usr/bin/cc and a cross-compile toolchain is used. We need to hand
diff --git a/lang/python310/pkg-plist b/lang/python310/pkg-plist
index 7de37fee9168..34a04ee2bf79 100644
--- a/lang/python310/pkg-plist
+++ b/lang/python310/pkg-plist
@@ -166,6 +166,7 @@ include/python%%XYDOT%%%%ABI%%/unicodeobject.h
include/python%%XYDOT%%%%ABI%%/warnings.h
include/python%%XYDOT%%%%ABI%%/weakrefobject.h
lib/libpython%%XYDOT%%%%ABI%%.so
+lib/libpython%%XYDOT%%%%ABI%%.so.1
lib/libpython%%XYDOT%%%%ABI%%.so.1.0
lib/libpython%%XYDOT%%%%ABI%%.so.1.0-gdb.py
lib/python%%XYDOT%%/LICENSE.txt