aboutsummaryrefslogtreecommitdiff
path: root/lang/python310
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2023-02-27 23:56:41 +0000
committerCharlie Li <vishwin@FreeBSD.org>2023-02-27 23:59:30 +0000
commit922e7f41450be113e7301c672c8ed3eb352cc8df (patch)
tree3fcde7747cfce7665ae1f00fe4d5686632b90d55 /lang/python310
parent96ba0cf90f0b0ef596be065c357ad4bd12399a44 (diff)
downloadports-922e7f41450be113e7301c672c8ed3eb352cc8df.tar.gz
ports-922e7f41450be113e7301c672c8ed3eb352cc8df.zip
lang/python: restore USES=python variables and SUB_LIST (no-op)
Has been a to do item for time. These are independent from but used by the bytecode trigger.
Diffstat (limited to 'lang/python310')
-rw-r--r--lang/python310/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/lang/python310/Makefile b/lang/python310/Makefile
index f3c13fc09ffd..14f3cc6bce3f 100644
--- a/lang/python310/Makefile
+++ b/lang/python310/Makefile
@@ -15,8 +15,8 @@ LICENSE= PSFL
LIB_DEPENDS= libffi.so:devel/libffi
-USES= compiler:c11 cpe ncurses pathfix pkgconfig readline \
- shebangfix ssl tar:xz
+USES= compiler:c11 cpe ncurses pathfix pkgconfig \
+ python:${PYTHON_DISTVERSION:R},env readline shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -26,11 +26,6 @@ SHEBANG_FILES+= Lib/test/ziptestdata/exe_with_z64 \
Lib/test/ziptestdata/exe_with_zip \
Lib/test/ziptestdata/header.sh
-# Duplicate python.mk variables. TODO: Let lang/python?? ports use python.mk bits.
-PYTHON_VER= ${PYTHON_DISTVERSION:R}
-PYTHON_VERSION= python${PYTHON_VER}
-PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
-
DISABLED_EXTENSIONS= _sqlite3 _tkinter _gdbm
CONFIGURE_ARGS+= --enable-shared --without-ensurepip \
--with-system-ffi