aboutsummaryrefslogtreecommitdiff
path: root/lang/python31
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-04-15 07:35:49 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-04-15 07:35:49 +0000
commit69dc0df90116f000db39228db9313afd99603ff8 (patch)
tree09a84c5da31504b937a100fb3e356d338f8ab9ab /lang/python31
parent86a4877f95bed16d3bbc975c9a83f39f5cafcb42 (diff)
downloadports-69dc0df90116f000db39228db9313afd99603ff8.tar.gz
ports-69dc0df90116f000db39228db9313afd99603ff8.zip
Upgrade to 1.5.1.
Notes
Notes: svn path=/head/; revision=10520
Diffstat (limited to 'lang/python31')
-rw-r--r--lang/python31/Makefile13
-rw-r--r--lang/python31/distinfo3
-rw-r--r--lang/python31/files/Setup32
-rw-r--r--lang/python31/pkg-plist55
4 files changed, 54 insertions, 49 deletions
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index f3c49252abef..2b965d0b9b72 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -3,24 +3,21 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.24 1998/04/08 09:23:57 tg Exp $
+# $Id: Makefile,v 1.25 1998/04/09 10:51:32 tg Exp $
#
-DISTNAME= python1.5
-PKGNAME= python-1.5
+DISTNAME= pyth151
+PKGNAME= python-1.5.1
CATEGORIES= lang tk80
MASTER_SITES= ftp://www.python.org/pub/python/src/ \
ftp://ftp.cwi.nl/pub/python/src/
-
-PATCH_SITES= http://www.python.org/1.5/
-PATCHFILES= all.txt
+EXTRACT_SUFX= .tgz
MAINTAINER= tg@FreeBSD.org
LIB_DEPENDS= ${TK_DEPENDS}
-DIST_SUBDIR= python
-WRKSRC= ${WRKDIR}/Python-1.5
+WRKSRC= ${WRKDIR}/Python-1.5.1
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-fpectl
MAKE_FLAGS= 'OPT=${CFLAGS}'
diff --git a/lang/python31/distinfo b/lang/python31/distinfo
index 8014abbcfc0c..63166bf98acb 100644
--- a/lang/python31/distinfo
+++ b/lang/python31/distinfo
@@ -1,2 +1 @@
-MD5 (python/python1.5.tar.gz) = 7964dcbae1e55e961549f0b4d4713711
-MD5 (python/all.txt) = c16d29e25ab01d1e21a94d5824502794
+MD5 (pyth151.tgz) = eb8ef6e37e543058a2d47996ecf62427
diff --git a/lang/python31/files/Setup b/lang/python31/files/Setup
index 41350fd89059..8599a9d17129 100644
--- a/lang/python31/files/Setup
+++ b/lang/python31/files/Setup
@@ -65,7 +65,7 @@ MACHDESTLIB=$(BINLIBDEST)
DESTPATH=
# Site specific path insertions -- should begin with : if non-empty
-SITEPATH=:NumPy
+SITEPATH=
# Standard enabled (tests are always available)
TESTPATH=:test
@@ -84,7 +84,6 @@ PYTHONPATH=$(COREPYTHONPATH)
# Some modules that are normally always on:
regex regexmodule.c regexpr.c # Regular expressions, GNU Emacs style
-reop reopmodule.c # Additional RE support (for re1.py)
pcre pcremodule.c pypcre.c # Regular expressions, Perl style (for re.py)
posix posixmodule.c # posix (UNIX) system calls
signal signalmodule.c # signal(2)
@@ -93,11 +92,14 @@ signal signalmodule.c # signal(2)
#gl glmodule.c -lgl -lX11 # Graphics Library -- SGI only
-# Thread module -- use only if Python has thread support for your OS.
-# Note that you must have configured (and built!) Python with the
-# --with-thread option passed to the configure script for this to work:
+# The thread module is now automatically enabled, see Setup.thread.
-#thread threadmodule.c
+# Pure module. Cannot be linked dynamically.
+# -DWITH_QUANTIFY, -DWITH_PURIFY, or -DWITH_ALL_PURE
+#WHICH_PURE_PRODUCTS=-DWITH_ALL_PURE
+#PURE_INCLS=-I/usr/local/include
+#PURE_STUBLIBS=-L/usr/local/lib -lpurify_stubs -lquantify_stubs
+#pure puremodule.c $(WHICH_PURE_PRODUCTS) $(PURE_INCLS) $(PURE_STUBLIBS)
# Uncommenting the following line tells makesetup that all following
# modules are to be built as shared libraries (see above for more
@@ -124,7 +126,7 @@ cmath cmathmodule.c # complex math library functions
math mathmodule.c -lm # math library functions, e.g. sin()
strop stropmodule.c # fast string operations implemented in C
struct structmodule.c # binary structure packing/unpacking
-time timemodule.c # time operations and variables
+time timemodule.c # -lm # time operations and variables
operator operator.c # operator.add() and similar goodies
_locale _localemodule.c # access to ISO C locale support
@@ -137,17 +139,19 @@ _locale _localemodule.c # access to ISO C locale support
fcntl fcntlmodule.c # fcntl(2) and ioctl(2)
pwd pwdmodule.c # pwd(3)
grp grpmodule.c # grp(3)
-crypt cryptmodule.c -lcrypt # crypt(3); needs -lcrypt on some systems
select selectmodule.c # select(2); not on ancient System V
socket socketmodule.c # socket(2); not on ancient System V
errno errnomodule.c # posix (UNIX) errno values
+# The crypt module is now disabled by default because it breaks builds
+# on many systems (where -lcrypt is needed), e.g. Linux (I believe).
+crypt cryptmodule.c -lcrypt # crypt(3); needs -lcrypt on some systems
+
*shared*
# Some more UNIX dependent modules -- off by default, since these
# are not supported by all UNIX systems:
-dbm dbmmodule.c # dbm(3) may require -lndbm or similar
nis nismodule.c # Sun yellow pages -- not everywhere
termios termios.c # Steen Lumholt's termios module
resource resource.c # Jeremy Hylton's rlimit interface
@@ -319,6 +323,16 @@ curses cursesmodule.c -lncurses -ltermcap
#dl dlmodule.c
+# Modules that provide persistent dictionary-like semantics. You will
+# probably want to arrange for at least one of them to be available on
+# your machine, though none are defined by default because of library
+# dependencies. The Python module anydbm.py provides an
+# implementation independent wrapper for these; dumbdbm.py provides
+# similar functionality (but slower of course) implemented in Python.
+
+# The standard Unix dbm module:
+
+dbm dbmmodule.c # dbm(3) may require -lndbm or similar
# Anthony Baxter's gdbm module (derived from Jack's dbm module)
# GNU dbm(3) will require -lgdbm:
diff --git a/lang/python31/pkg-plist b/lang/python31/pkg-plist
index 6d0e697c8732..59e319457559 100644
--- a/lang/python31/pkg-plist
+++ b/lang/python31/pkg-plist
@@ -73,9 +73,6 @@ lib/python1.5/ConfigParser.pyo
lib/python1.5/MimeWriter.py
lib/python1.5/MimeWriter.pyc
lib/python1.5/MimeWriter.pyo
-lib/python1.5/Para.py
-lib/python1.5/Para.pyc
-lib/python1.5/Para.pyo
lib/python1.5/Queue.py
lib/python1.5/Queue.pyc
lib/python1.5/Queue.pyo
@@ -94,9 +91,6 @@ lib/python1.5/UserDict.pyo
lib/python1.5/UserList.py
lib/python1.5/UserList.pyc
lib/python1.5/UserList.pyo
-lib/python1.5/addpack.py
-lib/python1.5/addpack.pyc
-lib/python1.5/addpack.pyo
lib/python1.5/aifc.py
lib/python1.5/aifc.pyc
lib/python1.5/aifc.pyo
@@ -136,9 +130,6 @@ lib/python1.5/cmpcache.pyo
lib/python1.5/code.py
lib/python1.5/code.pyc
lib/python1.5/code.pyo
-lib/python1.5/codehack.py
-lib/python1.5/codehack.pyc
-lib/python1.5/codehack.pyo
lib/python1.5/colorsys.py
lib/python1.5/colorsys.pyc
lib/python1.5/colorsys.pyo
@@ -195,9 +186,6 @@ lib/python1.5/fileinput.pyo
lib/python1.5/find.py
lib/python1.5/find.pyc
lib/python1.5/find.pyo
-lib/python1.5/fmt.py
-lib/python1.5/fmt.pyc
-lib/python1.5/fmt.pyo
lib/python1.5/fnmatch.py
lib/python1.5/fnmatch.pyc
lib/python1.5/fnmatch.pyo
@@ -213,6 +201,9 @@ lib/python1.5/ftplib.pyo
lib/python1.5/getopt.py
lib/python1.5/getopt.pyc
lib/python1.5/getopt.pyo
+lib/python1.5/getpass.py
+lib/python1.5/getpass.pyc
+lib/python1.5/getpass.pyo
lib/python1.5/glob.py
lib/python1.5/glob.pyc
lib/python1.5/glob.pyo
@@ -237,6 +228,9 @@ lib/python1.5/httplib.pyo
lib/python1.5/ihooks.py
lib/python1.5/ihooks.pyc
lib/python1.5/ihooks.pyo
+lib/python1.5/imaplib.py
+lib/python1.5/imaplib.pyc
+lib/python1.5/imaplib.pyo
lib/python1.5/imghdr.py
lib/python1.5/imghdr.pyc
lib/python1.5/imghdr.pyo
@@ -387,6 +381,9 @@ lib/python1.5/lib-tk/SimpleDialog.pyo
lib/python1.5/lib-tk/Tkconstants.py
lib/python1.5/lib-tk/Tkconstants.pyc
lib/python1.5/lib-tk/Tkconstants.pyo
+lib/python1.5/lib-tk/Tkdnd.py
+lib/python1.5/lib-tk/Tkdnd.pyc
+lib/python1.5/lib-tk/Tkdnd.pyo
lib/python1.5/lib-tk/Tkinter.py
lib/python1.5/lib-tk/Tkinter.pyc
lib/python1.5/lib-tk/Tkinter.pyo
@@ -411,9 +408,6 @@ lib/python1.5/linecache.pyo
lib/python1.5/locale.py
lib/python1.5/locale.pyc
lib/python1.5/locale.pyo
-lib/python1.5/lockfile.py
-lib/python1.5/lockfile.pyc
-lib/python1.5/lockfile.pyo
lib/python1.5/macpath.py
lib/python1.5/macpath.pyc
lib/python1.5/macpath.pyo
@@ -444,12 +438,6 @@ lib/python1.5/multifile.pyo
lib/python1.5/mutex.py
lib/python1.5/mutex.pyc
lib/python1.5/mutex.pyo
-lib/python1.5/newdir.py
-lib/python1.5/newdir.pyc
-lib/python1.5/newdir.pyo
-lib/python1.5/ni1.py
-lib/python1.5/ni1.pyc
-lib/python1.5/ni1.pyo
lib/python1.5/nntplib.py
lib/python1.5/nntplib.pyc
lib/python1.5/nntplib.pyo
@@ -494,6 +482,9 @@ lib/python1.5/poly.pyo
lib/python1.5/popen2.py
lib/python1.5/popen2.pyc
lib/python1.5/popen2.pyo
+lib/python1.5/poplib.py
+lib/python1.5/poplib.pyc
+lib/python1.5/poplib.pyo
lib/python1.5/posixfile.py
lib/python1.5/posixfile.pyc
lib/python1.5/posixfile.pyo
@@ -522,18 +513,12 @@ lib/python1.5/pyclbr.pyo
lib/python1.5/quopri.py
lib/python1.5/quopri.pyc
lib/python1.5/quopri.pyo
-lib/python1.5/rand.py
-lib/python1.5/rand.pyc
-lib/python1.5/rand.pyo
lib/python1.5/random.py
lib/python1.5/random.pyc
lib/python1.5/random.pyo
lib/python1.5/re.py
lib/python1.5/re.pyc
lib/python1.5/re.pyo
-lib/python1.5/re1.py
-lib/python1.5/re1.pyc
-lib/python1.5/re1.pyo
lib/python1.5/reconvert.py
lib/python1.5/reconvert.pyc
lib/python1.5/reconvert.pyo
@@ -570,6 +555,9 @@ lib/python1.5/shutil.pyo
lib/python1.5/site.py
lib/python1.5/site.pyc
lib/python1.5/site.pyo
+lib/python1.5/smtplib.py
+lib/python1.5/smtplib.pyc
+lib/python1.5/smtplib.pyo
lib/python1.5/sndhdr.py
lib/python1.5/sndhdr.pyc
lib/python1.5/sndhdr.pyo
@@ -591,9 +579,6 @@ lib/python1.5/sunaudio.pyo
lib/python1.5/symbol.py
lib/python1.5/symbol.pyc
lib/python1.5/symbol.pyo
-lib/python1.5/tb.py
-lib/python1.5/tb.pyc
-lib/python1.5/tb.pyo
lib/python1.5/telnetlib.py
lib/python1.5/telnetlib.pyc
lib/python1.5/telnetlib.pyo
@@ -656,6 +641,7 @@ lib/python1.5/test/output/test_timing
lib/python1.5/test/output/test_tokenize
lib/python1.5/test/output/test_types
lib/python1.5/test/output/test_unpack
+lib/python1.5/test/output/test_xmllib
lib/python1.5/test/output/test_zlib
lib/python1.5/test/pystone.py
lib/python1.5/test/pystone.pyc
@@ -822,6 +808,9 @@ lib/python1.5/test/test_types.pyo
lib/python1.5/test/test_unpack.py
lib/python1.5/test/test_unpack.pyc
lib/python1.5/test/test_unpack.pyo
+lib/python1.5/test/test_xmllib.py
+lib/python1.5/test/test_xmllib.pyc
+lib/python1.5/test/test_xmllib.pyo
lib/python1.5/test/test_zlib.py
lib/python1.5/test/test_zlib.pyc
lib/python1.5/test/test_zlib.pyo
@@ -834,6 +823,12 @@ lib/python1.5/test/testrgb.uue
lib/python1.5/test/tokenize_tests.py
lib/python1.5/test/tokenize_tests.pyc
lib/python1.5/test/tokenize_tests.pyo
+lib/python1.5/threading.py
+lib/python1.5/threading.pyc
+lib/python1.5/threading.pyo
+lib/python1.5/threading_api.py
+lib/python1.5/threading_api.pyc
+lib/python1.5/threading_api.pyo
lib/python1.5/toaiff.py
lib/python1.5/toaiff.pyc
lib/python1.5/toaiff.pyo