aboutsummaryrefslogtreecommitdiff
path: root/lang/python31
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-08-29 07:04:27 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-08-29 07:04:27 +0000
commit8f042a171a35127a844c4a4f764a9d0463da7785 (patch)
tree7b254b1ef1771ff978e2e2e298df1e5dbd384218 /lang/python31
parent9f11cd95b3603c5b8fb1775a76bc909306fcb177 (diff)
downloadports-8f042a171a35127a844c4a4f764a9d0463da7785.tar.gz
ports-8f042a171a35127a844c4a4f764a9d0463da7785.zip
Use tk-8.0. Minor makefile cleanups. Add some `@dirrm's in PLIST.
Notes
Notes: svn path=/head/; revision=7719
Diffstat (limited to 'lang/python31')
-rw-r--r--lang/python31/Makefile15
-rw-r--r--lang/python31/distinfo2
-rw-r--r--lang/python31/files/Setup2
-rw-r--r--lang/python31/pkg-plist10
4 files changed, 22 insertions, 7 deletions
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 349211934c37..74dccf93bca3 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -3,21 +3,23 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.15 1997/06/02 11:42:56 tg Exp $
+# $Id: Makefile,v 1.16 1997/08/06 06:40:27 tg Exp $
#
DISTNAME= python1.4
PKGNAME= python-1.4
-CATEGORIES= lang tk41
+CATEGORIES= lang tk80
MASTER_SITES= ftp://www.python.org/pub/python/src/ \
ftp://ftp.cwi.nl/pub/python/src/ \
ftp://www.python.org/pub/python/contrib/Graphics/Tkinter/ \
ftp://ftp.cwi.nl/pub/python/contrib/Graphics/Tkinter/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} _tkinter1.4.c
MAINTAINER= tg@FreeBSD.org
-LIB_DEPENDS= tk41\\.1\\.:${PORTSDIR}/x11/tk41
+LIB_DEPENDS= tk80\\.1\\.:${PORTSDIR}/x11/tk80
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
WRKSRC= ${WRKDIR}/Python-1.4
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-readline
@@ -31,12 +33,15 @@ MAN1= python.1
# installed. See 'man 3 pthread' for details on libc_r.
#
WITH_THREADS= yes
-SETUP_FILE= 'Setup'
+SETUP_FILE= Setup
.if exists(/usr/lib/libc_r.a) && defined(WITH_THREADS) && ${WITH_THREADS} == yes
CONFIGURE_ARGS+= --with-thread
-SETUP_FILE= 'Setup.thread'
+SETUP_FILE= Setup.thread
.endif
+post-extract:
+ ${CP} ${DISTDIR}/_tkinter1.4.c ${WRKSRC}/Modules/_tkinter.c
+
post-configure:
${CP} ${FILESDIR}/${SETUP_FILE} ${WRKSRC}/Modules/Setup
diff --git a/lang/python31/distinfo b/lang/python31/distinfo
index cc24c78b4b9c..cace99566462 100644
--- a/lang/python31/distinfo
+++ b/lang/python31/distinfo
@@ -1,2 +1,2 @@
MD5 (python1.4.tar.gz) = 341e3f3c688842024e70af6a99b5fb90
-MD5 (PyTix-1.12.tar.gz) = 03b90d29ee8f5c42ff0dbb920b1341af
+MD5 (_tkinter1.4.c) = 118b13afb519c58cfcccb47849ab6090
diff --git a/lang/python31/files/Setup b/lang/python31/files/Setup
index 7a6b60916c47..cab0cf57b1a5 100644
--- a/lang/python31/files/Setup
+++ b/lang/python31/files/Setup
@@ -250,7 +250,7 @@ TKPATH=:$(DESTLIB)/tkinter
#_tkinter _tkinter.c -I/usr/openwin/include -I/usr/local/include -L/usr/openwin/lib -L/usr/local/lib -ltk4.1 -ltcl7.5 -lX11
# For generic system (may have to add -I/-L options to find X11):
#_tkinter _tkinter.c -I/usr/local/include -L/usr/local/lib -ltk4.1 -ltcl7.5 -lX11
-_tkinter _tkinter.c -I${PREFIX}/include/tk4.1 -I${X11BASE}/include -L${PREFIX}/lib -L${X11BASE}/lib -ltk41 -ltcl75 -lX11
+_tkinter _tkinter.c -I${PREFIX}/include/tk8.0 -I${PREFIX}/include/tcl8.0 -I${X11BASE}/include -L${PREFIX}/lib -L${X11BASE}/lib -ltk80 -ltcl80 -lX11
# Lance Ellinghaus's modules:
diff --git a/lang/python31/pkg-plist b/lang/python31/pkg-plist
index 9627f1baa33b..ea3e038516d4 100644
--- a/lang/python31/pkg-plist
+++ b/lang/python31/pkg-plist
@@ -475,3 +475,13 @@ share/python1.4/whichdb.pyc
share/python1.4/whrandom.pyc
share/python1.4/xdrlib.pyc
share/python1.4/zmod.pyc
+@dirrm include/python1.4
+@dirrm lib/python1.4/config
+@dirrm lib/python1.4/sharedmodules
+@dirrm lib/python1.4
+@dirrm share/python1.4/stdwin
+@dirrm share/python1.4/tkinter
+@dirrm share/python1.4/test
+@dirrm share/python1.4/freebsd
+@dirrm share/python1.4/stdwin
+@dirrm share/python1.4