aboutsummaryrefslogtreecommitdiff
path: root/lang/python32/files
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-07-08 15:53:45 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-07-08 15:53:45 +0000
commit95340a84dc81dbf3fe8377e5a7d185b82ca5ea65 (patch)
tree0ddef3879cda667274ea8c93c7af429c924ee74b /lang/python32/files
parentd8634f008c0e05fb713e1c1d0be8d6ff7a72f15d (diff)
downloadports-95340a84dc81dbf3fe8377e5a7d185b82ca5ea65.tar.gz
ports-95340a84dc81dbf3fe8377e5a7d185b82ca5ea65.zip
- Update to 2.4a1, the first alpha release of Python 2.4.
- Provide USE_PYTHON_BUILD and USE_PYTHON_RUN to allow explicit dependencies. [1] - Provide PYDISTUTILS_CONFIGUREARGS and run ${PYSETUP} config on 'do-configure' targets. [2] Reviewed by: eik [1] Submitted by: Mike Brown <mike@skew.org>
Notes
Notes: svn path=/head/; revision=113222
Diffstat (limited to 'lang/python32/files')
-rw-r--r--lang/python32/files/patch-Lib-test-test_socket.py11
-rw-r--r--lang/python32/files/patch-Makefile.pre.in16
-rw-r--r--lang/python32/files/patch-setup.py11
3 files changed, 17 insertions, 21 deletions
diff --git a/lang/python32/files/patch-Lib-test-test_socket.py b/lang/python32/files/patch-Lib-test-test_socket.py
new file mode 100644
index 000000000000..33b9fb389f54
--- /dev/null
+++ b/lang/python32/files/patch-Lib-test-test_socket.py
@@ -0,0 +1,11 @@
+--- Lib/test/test_socket.py.orig Fri Jul 9 00:27:03 2004
++++ Lib/test/test_socket.py Fri Jul 9 00:27:11 2004
+@@ -289,7 +289,7 @@
+ # Find one service that exists, then check all the related interfaces.
+ # I've ordered this by protocols that have both a tcp and udp
+ # protocol, at least for modern Linuxes.
+- for service in ('echo', 'daytime', 'domain'):
++ for service in ('daytime', 'domain'):
+ try:
+ port = socket.getservbyname(service, 'tcp')
+ break
diff --git a/lang/python32/files/patch-Makefile.pre.in b/lang/python32/files/patch-Makefile.pre.in
deleted file mode 100644
index e2353b942195..000000000000
--- a/lang/python32/files/patch-Makefile.pre.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- Makefile.pre.in.orig Sat Sep 20 19:50:48 2003
-+++ Makefile.pre.in Sat Nov 15 22:34:55 2003
-@@ -714,11 +714,11 @@
- ./$(BUILDPYTHON) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST) -f \
- -x 'badsyntax|site-packages' $(DESTDIR)$(LIBDEST)
-- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
-+ -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
- ./$(BUILDPYTHON) -Wi -t $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST)/site-packages -f \
- -x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
-+ -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
- ./$(BUILDPYTHON) -Wi -t -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST)/site-packages -f \
- -x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
diff --git a/lang/python32/files/patch-setup.py b/lang/python32/files/patch-setup.py
index acf4e60dc734..003d0a4ae1fd 100644
--- a/lang/python32/files/patch-setup.py
+++ b/lang/python32/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Wed Oct 22 00:41:15 2003
-+++ setup.py Thu Oct 30 06:21:21 2003
+--- setup.py.orig Sun Jun 27 07:29:42 2004
++++ setup.py Thu Jul 8 23:55:04 2004
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,7 +9,7 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -770,7 +770,7 @@
+@@ -778,7 +778,7 @@
# Linux-specific modules
exts.append( Extension('linuxaudiodev', ['linuxaudiodev.c']) )
@@ -18,11 +18,12 @@
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
if platform == 'sunos5':
-@@ -1140,7 +1140,7 @@
+@@ -1160,8 +1160,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install
-- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle']
+- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
+- 'Lib/smtpd.py']
+ scripts = []
)