aboutsummaryrefslogtreecommitdiff
path: root/lang/python37/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2020-03-19 07:18:35 +0000
committerWen Heping <wen@FreeBSD.org>2020-03-19 07:18:35 +0000
commit35315d3538d1bc0cfbea3bdd8691529e313d0860 (patch)
tree7b03db59e634fe1c4d4b7f475b281ce6155a1f63 /lang/python37/Makefile
parent8b304ef939c0c17847672abe224a23ce13cde3cc (diff)
downloadports-35315d3538d1bc0cfbea3bdd8691529e313d0860.tar.gz
ports-35315d3538d1bc0cfbea3bdd8691529e313d0860.zip
- Update to 3.7.7
- Remove the LIBFFI option PR: 244782 Submitted by: wen@(myself) Exp-run by: antoine@
Notes
Notes: svn path=/head/; revision=528692
Diffstat (limited to 'lang/python37/Makefile')
-rw-r--r--lang/python37/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/lang/python37/Makefile b/lang/python37/Makefile
index 8d67478e446d..14ce6165f6bc 100644
--- a/lang/python37/Makefile
+++ b/lang/python37/Makefile
@@ -14,6 +14,8 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
+LIB_DEPENDS= libffi.so:devel/libffi
+
USES= cpe ncurses pathfix pkgconfig readline:port shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
@@ -27,7 +29,8 @@ PYTHON_VERSION= python${PYTHON_VER}
PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
DISABLED_EXTENSIONS= _sqlite3 _tkinter _gdbm
-CONFIGURE_ARGS+= --enable-shared --without-ensurepip
+CONFIGURE_ARGS+= --enable-shared --without-ensurepip \
+ --with-system-ffi
CONFIGURE_ENV+= OPT="" DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS}" # Null out OPT to respect user CFLAGS and remove optimizations
INSTALL_TARGET= altinstall # Don't want cloberring of unprefixed files
@@ -46,13 +49,12 @@ PLIST_SUB= ABI=${ABIFLAGS} \
XYZDOT=${PORTVERSION} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
-OPTIONS_DEFINE= DEBUG IPV6 LIBFFI NLS PYMALLOC
-OPTIONS_DEFAULT= LIBFFI PYMALLOC
+OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC
+OPTIONS_DEFAULT= PYMALLOC
OPTIONS_RADIO= HASH
OPTIONS_RADIO_HASH= FNV SIPHASH
OPTIONS_SUB= yes
-LIBFFI_DESC= Use libffi from ports instead of bundled version
NLS_DESC= Enable gettext support for the locale module
PYMALLOC_DESC= Enable specialized mallocs
@@ -66,9 +68,6 @@ SIPHASH_CONFIGURE_ON= --with-hash-algorithm=siphash24
DEBUG_CONFIGURE_WITH= pydebug
IPV6_CONFIGURE_ENABLE= ipv6
-LIBFFI_CONFIGURE_ON= --with-system-ffi
-LIBFFI_LIB_DEPENDS= libffi.so:devel/libffi
-
# Use CPPFLAGS over CFLAGS due to -I ordering, causing elementtree and pyexpat
# to break in Python 2.7, or preprocessor complaints in Python >= 3.3
# Upstream Issue: https://bugs.python.org/issue6299
@@ -96,12 +95,6 @@ PLIST_FILES+= bin/python${PYTHON_VER}${ABIFLAGS} \
libdata/pkgconfig/python-${PYTHON_VER}${ABIFLAGS}.pc
.endif
-# https://bugs.python.org/issue22521
-# https://bugs.python.org/issue23042
-.if ${ARCH} == i386 && !${PORT_OPTIONS:MLIBFFI}
-BROKEN= You must use libffi from ports on i386. Enable the LIBFFI option
-.endif
-
.if ${ARCH} == sparc64
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif