aboutsummaryrefslogtreecommitdiff
path: root/lang/python37/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-08-26 18:42:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-08-26 18:42:37 +0000
commit49c5e9180d451f714d48ffcfebfb2d8ca92921b8 (patch)
treecb9aaeef8e87a26b51bea24d40244f1af073e879 /lang/python37/Makefile
parent77168db607ecfc8e3db968d77eec890801178a34 (diff)
downloadports-49c5e9180d451f714d48ffcfebfb2d8ca92921b8.tar.gz
ports-49c5e9180d451f714d48ffcfebfb2d8ca92921b8.zip
Remove THREADS option
- Bump PORTREVISION for package change Support for building --without-threads has been removed. The threading module is now always available. PR: 230605 Submitted by: Roland Smith <rsmith@xs4all.nl> Reference: https://docs.python.org/3/whatsnew/3.7.html
Notes
Notes: svn path=/head/; revision=478157
Diffstat (limited to 'lang/python37/Makefile')
-rw-r--r--lang/python37/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/lang/python37/Makefile b/lang/python37/Makefile
index 3faa9e8e993f..1bbbaa4ae7ca 100644
--- a/lang/python37/Makefile
+++ b/lang/python37/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= python
-PORTREVISION= 2
PORTVERSION= ${PYTHON_PORTVERSION}
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
@@ -48,8 +48,8 @@ PLIST_SUB= ABI=${ABIFLAGS} \
XYZDOT=${PORTVERSION} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
-OPTIONS_DEFINE= DEBUG IPV6 LIBFFI NLS PYMALLOC THREADS
-OPTIONS_DEFAULT= LIBFFI PYMALLOC THREADS
+OPTIONS_DEFINE= DEBUG IPV6 LIBFFI NLS PYMALLOC
+OPTIONS_DEFAULT= LIBFFI PYMALLOC
OPTIONS_RADIO= HASH
OPTIONS_RADIO_HASH= FNV SIPHASH
OPTIONS_SUB= yes
@@ -81,9 +81,6 @@ NLS_CONFIGURE_ENV_OFF= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
PYMALLOC_CONFIGURE_WITH= pymalloc
-THREADS_CONFIGURE_WITH= threads
-THREADS_LDFLAGS= -lpthread
-
.include "${.CURDIR}/Makefile.version"
.include <bsd.port.options.mk>