aboutsummaryrefslogtreecommitdiff
path: root/lang/python38/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2023-02-27 21:01:32 +0000
committerMatthias Andree <mandree@FreeBSD.org>2023-02-27 21:04:52 +0000
commita9d9d3a4272303bf226b9deb55c42303e4fcebdc (patch)
treeba0584b450ab30f0fb60240580bf79b3b45d8671 /lang/python38/Makefile
parentd20b28d5495100ed8b93b69253b3fdc002448053 (diff)
downloadports-a9d9d3a4272303bf226b9deb55c42303e4fcebdc.tar.gz
ports-a9d9d3a4272303bf226b9deb55c42303e4fcebdc.zip
lang/python: Revert "add bytecode trigger"
This reverts commit c17ddfbf66e2801ec620d49979aca3d7077d7002. This causes breakage on several ports, and the next iteration requires a full exp-run. See: Differential Revision: https://reviews.freebsd.org/D34739
Diffstat (limited to 'lang/python38/Makefile')
-rw-r--r--lang/python38/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/lang/python38/Makefile b/lang/python38/Makefile
index 056ff45a8f98..07d227c23956 100644
--- a/lang/python38/Makefile
+++ b/lang/python38/Makefile
@@ -1,6 +1,6 @@
PORTNAME= python
DISTVERSION= ${PYTHON_DISTVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python
MASTER_SITES= PYTHON/ftp/python/${DISTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
@@ -15,8 +15,7 @@ LICENSE= PSFL
LIB_DEPENDS= libffi.so:devel/libffi
-USES= cpe ncurses pathfix pkgconfig python:${PYTHON_DISTVERSION:R},env readline \
- shebangfix ssl tar:xz trigger
+USES= cpe ncurses pathfix pkgconfig readline shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -25,7 +24,11 @@ SHEBANG_FILES= Lib/*.py Lib/*/*.py Lib/*/*/*.py Lib/*/*/*/*.py
SHEBANG_FILES+= Lib/test/ziptestdata/exe_with_z64 \
Lib/test/ziptestdata/exe_with_zip \
Lib/test/ziptestdata/header.sh
-TRIGGERS= ${PYTHON_VERSION}
+
+# Duplicate python.mk variables. TODO: Let lang/python?? ports use python.mk bits.
+PYTHON_VER= ${PYTHON_DISTVERSION:R}
+PYTHON_VERSION= python${PYTHON_VER}
+PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
DISABLED_EXTENSIONS= _sqlite3 _tkinter _gdbm
CONFIGURE_ARGS+= --enable-shared --without-ensurepip \