aboutsummaryrefslogtreecommitdiff
path: root/lang/python38
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-04-09 13:28:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-05-25 13:55:44 +0000
commit5f69415313f894338dca54e21b5c3981e5e5f58f (patch)
tree936ed6c9018556107a7d166f0862aae19bf6c652 /lang/python38
parent40d7b487381cc91eb3156103e6ffe8c02d5e8a70 (diff)
downloadports-5f69415313f894338dca54e21b5c3981e5e5f58f.tar.gz
ports-5f69415313f894338dca54e21b5c3981e5e5f58f.zip
Mk: switch from PYTHON_PORTVERSION to PYTHON_DISTVERSION
This brings python framework in consistense with handbook recommendations to prefer DISTVERSION and simplifies adding prerelease versions of python PR: 255013 Differential Revision: https://reviews.freebsd.org/D29418 Exp-run by: antoine Approved by: wen@, no objection from python@ or portmgr@
Diffstat (limited to 'lang/python38')
-rw-r--r--lang/python38/Makefile12
-rw-r--r--lang/python38/Makefile.version2
2 files changed, 7 insertions, 7 deletions
diff --git a/lang/python38/Makefile b/lang/python38/Makefile
index ecc3e9ca22c1..be973fca11ac 100644
--- a/lang/python38/Makefile
+++ b/lang/python38/Makefile
@@ -1,11 +1,11 @@
# Created by: Kubilay Kocak <koobs@FreeBSD.org>
PORTNAME= python
-PORTVERSION= ${PYTHON_PORTVERSION}
+DISTVERSION= ${PYTHON_DISTVERSION}
CATEGORIES= lang python
-MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
+MASTER_SITES= PYTHON/ftp/python/${DISTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
-DISTNAME= Python-${PORTVERSION}
+DISTNAME= Python-${DISTVERSION}
DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
@@ -17,14 +17,14 @@ USES= cpe ncurses pathfix pkgconfig readline shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
+python_CMD= ${PREFIX}/bin/python${PYTHON_DISTVERSION:R}
SHEBANG_FILES= Lib/*.py Lib/*/*.py Lib/*/*/*.py Lib/*/*/*/*.py
SHEBANG_FILES+= Lib/test/ziptestdata/exe_with_z64 \
Lib/test/ziptestdata/exe_with_zip \
Lib/test/ziptestdata/header.sh
# Duplicate python.mk variables. TODO: Let lang/python?? ports use python.mk bits.
-PYTHON_VER= ${PYTHON_PORTVERSION:R}
+PYTHON_VER= ${PYTHON_DISTVERSION:R}
PYTHON_VERSION= python${PYTHON_VER}
PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
@@ -45,7 +45,7 @@ SUB_LIST= PYTHON_SUFFIX=${PYTHON_SUFFIX}
PLIST_SUB= ABI=${ABIFLAGS} \
XY=${PYTHON_SUFFIX} \
XYDOT=${PYTHON_VER} \
- XYZDOT=${PORTVERSION} \
+ XYZDOT=${DISTVERSION} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
OPTIONS_DEFINE= DEBUG IPV6 LIBFFI LIBMPDEC NLS PYMALLOC
diff --git a/lang/python38/Makefile.version b/lang/python38/Makefile.version
index 12ed93354d24..7620495e8fc2 100644
--- a/lang/python38/Makefile.version
+++ b/lang/python38/Makefile.version
@@ -2,4 +2,4 @@
# Do not forget to update python documentation (lang/python-doc-*)
# Run "make -C lang/python-doc-html makesum"
-PYTHON_PORTVERSION= 3.8.10
+PYTHON_DISTVERSION= 3.8.10