aboutsummaryrefslogtreecommitdiff
path: root/lang/rexx-imc
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-11-17 17:42:48 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-11-17 17:42:48 +0000
commit75f93b8b8c9e605bbbaeb8c02ac58e50d89e3f83 (patch)
tree67bc6d1dbed5a212793f14438fed3a227977b1fd /lang/rexx-imc
parente196b0f29ae0dc668e6b7f14849698bfd29556c6 (diff)
Fix build on aarch64.
While here, pet portlint. PR: 251098 Submitted by: mikael
Notes
Notes: svn path=/head/; revision=555572
Diffstat (limited to 'lang/rexx-imc')
-rw-r--r--lang/rexx-imc/Makefile4
-rw-r--r--lang/rexx-imc/files/patch-Makefile.REXXimc9
2 files changed, 11 insertions, 2 deletions
diff --git a/lang/rexx-imc/Makefile b/lang/rexx-imc/Makefile
index 5a036b0fd123..8ac81ccfe88d 100644
--- a/lang/rexx-imc/Makefile
+++ b/lang/rexx-imc/Makefile
@@ -11,11 +11,11 @@ MASTER_SITES= http://www.cs.ox.ac.uk/people/ian.collier/distribution/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Procedural programming language designed by IBM's UK Laboratories
-CONFLICTS= rexx-regina-* oorexx-[0-9]*
-
BROKEN_armv6= fails to link: /nxb-bin/usr/bin/ld: hidden symbol __aeabi_uidivmod in libgcc.a is referenced by DSO
BROKEN_armv7= fails to link: /nxb-bin/usr/bin/ld: hidden symbol __aeabi_uidivmod in libgcc.a is referenced by DSO
+CONFLICTS= rexx-regina-* oorexx-[0-9]*
+
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Make
CONFIGURE_ENV= PREFIX="${PREFIX}"
diff --git a/lang/rexx-imc/files/patch-Makefile.REXXimc b/lang/rexx-imc/files/patch-Makefile.REXXimc
index b435f31cfe1e..6213ba9b1816 100644
--- a/lang/rexx-imc/files/patch-Makefile.REXXimc
+++ b/lang/rexx-imc/files/patch-Makefile.REXXimc
@@ -35,3 +35,12 @@
$(LIBDIR)/librexx.a: $(LIBFILES)
$(VERBOSE) "$(LIBDIR)/librexx.a:"
+@@ -143,7 +144,7 @@ interface.o: $(SRC)/interface.c $(HFILES)
+ rxmathfn.rxfn: $(SRC)/rxmathfn.c $(SRC)/const.h $(SRC)/functions.h
+ $(VERBOSE) "rxmathfn.rxfn:"
+ $(CC) $(OPTFLAG) $(CCFLAG) -c $(PIC) -I$(SRC) $(SRC)/rxmathfn.c
+- $(LD) $(SOFLAG) -o rxmathfn.rxfn rxmathfn.o -lm
++ $(LD) $(SOFLAG) -o rxmathfn.rxfn rxmathfn.o -L/usr/lib -lm
+ @rm rxmathfn.o
+
+ # If the source is in the current directory, this rule can be used.