aboutsummaryrefslogtreecommitdiff
path: root/lang/rubinius/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 09:45:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 09:45:36 +0000
commit4a4ec28d37b64039d4eff0f34ad66b543767d758 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /lang/rubinius/Makefile
parenta5d24d4bb4a43375b4bbb7f8bc673f8c557f06b4 (diff)
downloadports-4a4ec28d37b64039d4eff0f34ad66b543767d758.tar.gz
ports-4a4ec28d37b64039d4eff0f34ad66b543767d758.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Notes
Notes: svn path=/head/; revision=352986
Diffstat (limited to 'lang/rubinius/Makefile')
-rw-r--r--lang/rubinius/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/rubinius/Makefile b/lang/rubinius/Makefile
index e3e24a3e57b7..3e7ec642e8ba 100644
--- a/lang/rubinius/Makefile
+++ b/lang/rubinius/Makefile
@@ -46,7 +46,7 @@ PLIST_SUB+= FREEBSD_DIR=${FREEBSD_DIR}
# Hack to prevent rbx from creating $HOME/.rbx during compilation of gems
MAKE_ENV+= HOME=${WRKSRC}
-F_OS= ${OPSYS:L}
+F_OS= ${OPSYS:tl}
F_MAJOR= ${OSREL:C/\..*$//}
FREEBSD_DIR= ${F_ARCH}-${F_OS}-${F_MAJOR}