aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby-programmingruby/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-07 17:50:50 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-07 17:50:50 +0000
commit0c1a8b25083bc17a64c68a38f68b0081be8e42af (patch)
tree7130b67c13552076b9407403e2a16fe5d6679a1f /lang/ruby-programmingruby/Makefile
parentc0dbea723a3744fb85aaef344965f53d060c2f91 (diff)
downloadports-0c1a8b25083bc17a64c68a38f68b0081be8e42af.tar.gz
ports-0c1a8b25083bc17a64c68a38f68b0081be8e42af.zip
Add ruby-programmingruby, the source of the Programming Ruby
("pick-axe") book in XML and HTML. It is released under the Open Publication license.
Notes
Notes: svn path=/head/; revision=39192
Diffstat (limited to 'lang/ruby-programmingruby/Makefile')
-rw-r--r--lang/ruby-programmingruby/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/lang/ruby-programmingruby/Makefile b/lang/ruby-programmingruby/Makefile
new file mode 100644
index 000000000000..63b44c7a048e
--- /dev/null
+++ b/lang/ruby-programmingruby/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Programming Ruby
+# Date created: 8 February 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= programmingruby
+PORTVERSION= 0.2
+CATEGORIES= lang ruby
+MASTER_SITES= http://www.rubycentral.com/downloads/files/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ProgrammingRuby-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+RUBY_NO_BUILD_DEPENDS= yes
+RUBY_NO_RUN_DEPENDS= yes
+
+NO_BUILD= yes
+
+DOCDIR= ${RUBY_DOCDIR}/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${DOCDIR}
+ ${CP} -R ${WRKSRC}/* ${DOCDIR}/
+
+.include <bsd.port.mk>